Results 1 to 13 of 13
  1. #1
    Join Date
    Mar 2003
    Location
    18 Sur 3917
    Posts
    17

    Unanswered: Oracle Client 9i - sqlplus

    Hi I have this problem to connect my linux RH 8 with Oracle client 9i.

    I want to connect the sqlplus with the oracle server

    I did that :

    1. Install oracle client 9i for linux.
    2. Config the tnsnames.ora
    3. Run the netca to test the connection an this one was succesful


    My tnsnames is:

    Beq-local.world =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS =
    (PROTOCOL = BEQ)
    (PROGRAM = oracle80)
    (ARGV0 = oracle80ORCL)
    (ARGS = '(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq))) ')
    )
    )
    (CONNECT_DATA = (SID = ORCL)
    )
    )
    Tcp-loopback.world =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS =
    (PROTOCOL = TCP)
    (Host = 127.0.0.1)
    (Port = 1521)
    )
    )
    (CONNECT_DATA = (SID = ORCL)
    )

    RECHUM =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 172.21.9.30)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = RECHUM)
    )
    )

    and when I try to make the connection like this:

    $./sqlplus urechum/urechum@rechum

    SQL*Plus: Release 9.2.0.1.0 - Production on Wed Mar 12 09:18:45 2003

    Copyright (c) 1982, 2002, Oracle Corporation. All rights reserved.

    ERROR:
    ORA-12154: TNS:could not resolve service name

    the users and password are correct, and I think the tnsnames.ora are correct to because with windows I do a good connection.

    Some idea.

    thanks

  2. #2
    Join Date
    Feb 2003
    Location
    Germany
    Posts
    20

    Re: Oracle Client 9i - sqlplus

    [I had the same problem till I noticed that I misspelled the service name. Are you shure that such a Database exists on the remote host ?

    Greetings Jürgen

  3. #3
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482
    See if in sqlnet.ora file you have SQLNET.DEFAULT_DOMAIN=WORLD.

    If so either add .WORLD to RECHUM TNS alias, or comment out the line.



    Hope that helps,

    clio_usa - OCP - DBA


  4. #4
    Join Date
    Nov 2002
    Posts
    833
    is the listener.ora containing the SID RECHUM
    and is lsnrctl stat showing a listener for rechum ?

  5. #5
    Join Date
    Feb 2003
    Location
    Germany
    Posts
    20
    does a

    tnsping rechnum

    works ??

  6. #6
    Join Date
    Mar 2003
    Location
    18 Sur 3917
    Posts
    17
    Hi Thank you for answer me.

    1. I search and I dont have sqlnet.ora

    I create some lake this:

    # SQLNET.ORA Network Configuration File: /u01/app/oracle/product/8.1.7.0.1/network/admin/sqlnet.ora
    # Generated by Oracle configuration tools.

    TRACE_LEVEL_CLIENT=USER
    sqlnet.expire_time = 30
    NAMES.DIRECTORY_PATH= (TNSNAMES, ONAMES, HOSTNAME)
    NAMES.DEFAULT_DOMAIN=world
    NAME.DEFAULT_ZONE=world

    I dont kown is that is ok

    2. The connection of the server is good because the windows pc works.

    3. I try it tnsping looks ok

    [oracle@fespinosa admin]$ tnsping RECHUM

    TNS Ping Utility for Linux: Version 9.2.0.1.0 - Production on 13-MAR-2003 11:29:41

    Copyright (c) 1997 Oracle Corporation. All rights reserved.

    Used parameter files:


    Used TNSNAMES adapter to resolve the alias
    )SERVICE_NAME = RECHUM)TCP)(HOST = 172.21.9.30)(PORT = 1521))
    OK (0 msec)

    but with the sql.ora does not works.

    the ./sqplus still not working

    Thanks... I wait yours answers.

    Regards.

  7. #7
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482

    Smile

    As I said before - of you have NAMES.DEFAULT_DOMAIN=world in your sqlnet.ora file, you have to change the tnsnames.ora file entry for RECHUN to:

    RECHUM.WORLD =
    (DESCRIPTION =
    (ADDRESS_LIST =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 172.21.9.30)(PORT = 1521))
    )
    (CONNECT_DATA =
    (SERVICE_NAME = RECHUM)
    )
    )


    Did you do that or not?


    Hope that helps,

    clio_usa - OCP - DBA


  8. #8
    Join Date
    Mar 2003
    Location
    18 Sur 3917
    Posts
    17
    Of course I did.

    I can do it this:

    $tnsping rechum.world

    and is good.

    but with sqlplus

    is not good.

    Best Regards.

  9. #9
    Join Date
    Mar 2003
    Posts
    12
    It seems like you have several tnsnames.ora files, check that you are using just one. You can set the TNS_ADMIN environment variable to define the directory where sqlplus will get the tnsnames.ora

    Check that the SID are the same between tnsnames.ora (client) and listener.ora (server).

    If the error persist, then try this, change de entry:
    (SERVICE_NAME = RECHUM)
    for
    (SID_NAME = RECHUM)

    Hope that helps
    US.

  10. #10
    Join Date
    Feb 2003
    Posts
    45

    TWO_TASK

    Maybe :-

    If u r connecting from Windows to Oracle under Unix/Linux
    then sometimes you need to set the environment variable TWO_TASK.

    This ought to be set to the same service name as the SID you want to connect to (?)

    SET TWO_TASK=<........>

    Then try your sqlplus ..... etc

  11. #11
    Join Date
    Mar 2003
    Location
    18 Sur 3917
    Posts
    17
    Thank you everybody.

    For your help I resolve the problem.

    thaks a lot.

  12. #12
    Join Date
    Mar 2003
    Posts
    3

    Oracle 9i Client for Linux

    Would someone tell me where I can found an Oracle 9i Client for Linux software???


    Sincerellu...,

    Fernando.

  13. #13
    Join Date
    Mar 2003
    Location
    18 Sur 3917
    Posts
    17

    Smile Re: Oracle 9i Client for Linux

    On the oracle page, Download>Linux> something like that and try to find the Oracle Database 9i. I dont remember but perhaps

    the client is inside the Database.

    Regards...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •