Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2003
    Location
    New York
    Posts
    4

    Red face Unanswered: Oracle 8i Listener stops working

    Hello all,

    I installed Oracle 8i (8.1.7) on a NT 4.0 SP6 box. I went through the minimal install with no problems. Created a new database and again no problems. From the server I can connect to the database with no problems (I guess it's using the IPC protocol), however when I try to connect from any client (win2k, winXP) I get "ORA-12545: Connect failed because target host or object does not exist".

    Now the funny part is that if I restart the listener and connect immediately after I can connect to the database and run queries with no problem. If I try to connect after one or two minutes of having restarted the databaseI get the error message, the only way to successfully establish the connection is by restarting the Listener.

    Connecting from the server using SQL/PLUS is not a problem, when using SQL/PLUS from a client workstation I get the error message. I also took a look at the Listener log file and it actually logs the connection attemps even the failed ones.

    Any help will be greatly appreciated, thanks.

  2. #2
    Join Date
    Mar 2003
    Location
    New York
    Posts
    4

    Listener Status

    Hello all,

    After I restart the TNSLISTER and view the status this is what I get:
    -----------------------------------------------------------------------------
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for 32-bit Win
    tion
    Start Date 12-MAR-2003 11:42:51
    Uptime 0 days 0 hr. 0 min. 2
    Trace Level user
    Security OFF
    SNMP OFF
    Listener Parameter File E:\oracle\ora83\networ
    Listener Log File E:\oracle\ora83\networ
    Listener Trace File E:\oracle\ora83\networ
    Services Summary...
    PLSExtProc has 1 service handler(s)
    PowSign has 1 service handler(s)

    After a couple of minutes and view the status of the listener this is what I get:
    -----------------------------------------------------------------------
    STATUS of the LISTENER
    ------------------------
    Alias LISTENER
    Version TNSLSNR for 32-bit Windo
    tion
    Start Date 12-MAR-2003 11:42:51
    Uptime 0 days 0 hr. 1 min. 57 s
    Trace Level user
    Security OFF
    SNMP OFF
    Listener Parameter File E:\oracle\ora83\network\
    Listener Log File E:\oracle\ora83\network\
    Listener Trace File E:\oracle\ora83\network\
    Services Summary...
    PLSExtProc has 1 service handler(s)
    PowSign has 1 service handler(s)
    PowSign has 2 service handler(s)

    ------------------------------------------------------------------------
    I noticed that the database has a total of 3 service handlers after a couple of minutes of running. As to why this is happening I have no idea.

    Again any help will be greatly appreciated.

  3. #3
    Join Date
    Dec 2002
    Location
    Netherlands
    Posts
    118
    Hi

    Please post your listener.log file

    Remi
    Remi Visser

    Oracle Database Administrator
    (OCP certified 8i)

    Homepage: http://home.remidian.com/

  4. #4
    Join Date
    Mar 2003
    Location
    New York
    Posts
    4
    Thanks for responding I've attached the Log file as txt document.
    Attached Files Attached Files

  5. #5
    Join Date
    Mar 2003
    Location
    New York
    Posts
    4
    This is the trace file again in a txt document.
    Attached Files Attached Files

  6. #6
    Join Date
    Apr 2003
    Posts
    1
    This is a known bug in Linux.

    You only have to comment all mts entries at your init.ora

    I hope this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •