Results 1 to 9 of 9
  1. #1
    Join Date
    Sep 2002
    Location
    South Wales
    Posts
    580

    Lightbulb Unanswered: Supress Office Message

    I have an access 2000 application which incoproates a form showing links to external doccuments: Drawings and the like

    These links are command buttons with a hyperlink

    For some doccuments clicking on the associated button will give an Office warning message:

    Microsoft Office

    Openingfile name and path)

    Some files can contain viruses or otherwise be harmful to your computer. It is important to be certain that this file is from a trustworthy source.

    Would you like to open this file?

    OK / CANCEL

    I would like to supress this pop-up programatically, although

    docmd setwarnings false

    Does not do the trick

    Any ideas folks?

  2. #2
    Join Date
    Apr 2002
    Posts
    139
    Old Fashioned, but using SendKeys may do the trick.

  3. #3
    Join Date
    Feb 2003
    Location
    Wichita,KS
    Posts
    44
    I’m having the same problem with the popup message. Has anyone come up with a way to disable this message?

  4. #4
    Join Date
    Aug 2003
    Location
    Phoenix, AZ
    Posts
    12
    The syntax in VB is supposed to be docmd.setwarnings false. I think the edit defaults to VB syntax. Try putting in the period/dot.

  5. #5
    Join Date
    Feb 2003
    Location
    Wichita,KS
    Posts
    44
    The VB docmd.setwarnings does not help in this case. This goes beyond just VB code.
    The following is from Microsoft Knowledge Base Article - 291912

    “CAUSE
    The warning message described in the "Symptoms" section of this article is issued by Microsoft Office. This warning is referred to as the "open programs" warning, not the "macro virus protection" warning. It appears any time that you click a hyperlink to a program or run a program. You also receive this warning when you click a hyperlink to certain types of document files. You cannot disable this warning. Similar behavior occurs in other Microsoft Office programs that allow you to use hyperlinks.

    This feature is designed into Microsoft Office to help protect you from malicious code.

    WORKAROUND
    For any Microsoft Office program, you can work around this behavior by viewing the page in a Web browser.”

    Unfortunately for me, my management wants a direct link to the employee handbook on our intranet which is a pdf not html.

  6. #6
    Join Date
    Sep 2003
    Posts
    2

    Smile Re: Supress Office Message

    It's true this is a Microsoft Office message, but you CAN turn it off, at least in Windows 2000. In any folder window: Tools/Folder Options/FileTypes/. Then select the file-type that is causing the warning message (e.g., ZIP). Press ADVANCED. Then UNCHECK the "confirm open after download." Next time you try to hyperlink to a file of this type, you won't get the warning.

  7. #7
    Join Date
    Feb 2003
    Location
    Wichita,KS
    Posts
    44
    Thanks for the reply but unfortunately it did not work.
    I am running Windows 2000 Professional with Office 2000. The hyperlink is on a form in my database. It still gives me the warning every time I click the link.
    My database is not on the intranet, I just wanted to display a pdf file that is on our intranet.

  8. #8
    Join Date
    Sep 2003
    Posts
    2
    That's exactly my environment too - Windows 2K, Office 2K, and Access 2K. When I hyperlinked to a zip file from an Access form, I got the warning message until I unchecked the "confirm open after download" button for ZIP files in the folder options. Are you sure you did this for EACH file type in question? I don't know what else could be different between our environments, since it works 100% for me. See attached screen shot showing the box UNchecked.
    Attached Thumbnails Attached Thumbnails openwarn.jpg  

  9. #9
    Join Date
    Feb 2003
    Location
    Wichita,KS
    Posts
    44
    I’ve done some playing around with this and I get mixed results.

    If I open the file on my local drive or on a network volume I don’t get the message displayed. But when I open it from an intranet link I get the message every time. Apparently the http: in the file location triggers the warning message.

    I convinced management to accept a link to the web page that contains a link to the document rather than subjecting the users to the warning message every time.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •