Results 1 to 1 of 1

Thread: unique Problem

  1. #1
    Join Date
    Mar 2003
    Location
    Memphis, TN, USA
    Posts
    61

    Red face Unanswered: unique Problem

    Hi there,

    I have a wee problem with the INSERT statement. The problem is very unusual. I would like yours help in the same. The problem is.... Mine files are running very well on my IIS but when i posted on the net, it prompts me error messages. The error which it prompt is...
    Microsoft OLE DB Provider for ODBC Drivers error '80040e14'

    [Microsoft][ODBC SQL Server Driver][SQL Server]Insert Error: Column name or number of supplied values does not match table definition.

    /minorities/postrec.asp, line 34

    In brief, i would like to put some lights on the code and database. It's a very simple program in which user fill up their events details in the form and the vaules of that form is going to store in the database.The database contain one "AUTO-INCREMENT" fileds which is increment by 1 every times a new records is added. I am using SQL 2000 and ASP.

    The snapshot of Insert statement is :

    strsql="insert into recruitment values('"& Request("title") & "','"& Request("cname") & "' , '" _

    & request("cdesc") &"' , '"& request("country") &"','"& request("state") &"' , '"& request("ind") &"' , '" _

    & request("indother") &"' , '"& request("level") &"','"& request("jobdesig") &"' , '"& request("jobfun") &"', '" _

    & request("jobdesc") &"' , '"& request("currency") &"','"& request("lsalary") &"' , '"& request("hsalary") &"', '" _

    & request("chkperks") &"' , '"& request("rdohousing") &"','"& request("numvac") &"' , '"& request("degree") &"', '" _

    & request("workexp") &"','"& request("add_info") &"','"& request("email") &"', '"& request("sms") &"', '" _

    & request("address1") &"', '"& request("address2") &"', '"& request("pincode") &"','"& request("contry") &"', '" _

    & request("constate") &"' , '"& request("city") &"','"& request("teloff") &"','"& request("telhome") &"','"& request("postaddress") &"')"

    set recordset = connection.execute(strsql)

    I am very well aware what the error message means. But, both tables and files are same. One run fines on my IIS but other show the above mentions error.

    What am I doing wrong? I suspect that it might be related to the autoincrement field. Or it might be that I just plain can't do this?

    I am attaching the sql file also with this email.

    Any answers or suggestion( for debugging) are most welcome.

    Thanks for your anticipations.
    shyam
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •