Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2003
    Posts
    5

    Unanswered: blob selection problems

    Hey everyone
    I hope some of you experts can help me out.
    I just upgraded my client to db2 8.1 and my sever db is still v7.1
    Everything seems to work fine but when i try to extract a blob from a table i receive the following message ("Select pdfBlob from blob table"
    )
    --->

    SQL0351N An unsupported SQLTYPE was encountered in position "1

    " of the output SQLDA (select list).

    Explanation:

    The element of the SQLDA at position "<position-number>" is for
    a data type that either the application requestor or the
    application server does not support. If the application is not
    using the SQLDA directly, "<position-number>" could represent the
    position of an element in the select list or a parameter of a
    CALL statement.

    The statement cannot be processed.

    User Response:

    Change the statement to exclude the unsupported data type. For
    a select statement, remove the names of any columns in the
    select-list with the unsupported data type or use a cast in the
    query to cast the column to a supported data type.

    sqlcode : -351

    sqlstate : 56084
    ---->

    it seems that the type is not supported, i'm not too sure what changed when upgraded my client. When i was running the client for 7.1 everything was peachy!

    Any info you guys can give me would be greatly appreciated.

    thanks

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: blob selection problems

    Please go through the comaptability section of DB2 V8 - what's new before doing any version upgrade

    There is a section on limitations of having the clients and servers, one in 7 and the other in 8, in the same document ..

    HTH

    Cheers

    Sathyaram

    Originally posted by mjoc13
    Hey everyone
    I hope some of you experts can help me out.
    I just upgraded my client to db2 8.1 and my sever db is still v7.1
    Everything seems to work fine but when i try to extract a blob from a table i receive the following message ("Select pdfBlob from blob table"
    )
    --->

    SQL0351N An unsupported SQLTYPE was encountered in position "1

    " of the output SQLDA (select list).

    Explanation:

    The element of the SQLDA at position "<position-number>" is for
    a data type that either the application requestor or the
    application server does not support. If the application is not
    using the SQLDA directly, "<position-number>" could represent the
    position of an element in the select list or a parameter of a
    CALL statement.

    The statement cannot be processed.

    User Response:

    Change the statement to exclude the unsupported data type. For
    a select statement, remove the names of any columns in the
    select-list with the unsupported data type or use a cast in the
    query to cast the column to a supported data type.

    sqlcode : -351

    sqlstate : 56084
    ---->

    it seems that the type is not supported, i'm not too sure what changed when upgraded my client. When i was running the client for 7.1 everything was peachy!

    Any info you guys can give me would be greatly appreciated.

    thanks

  3. #3
    Join Date
    Mar 2003
    Posts
    5

    Re: blob selection problems

    Sorry to bug you
    But would know where to look for these compatability issues?
    I'm looking on the ibm site, but it's not very good at returning my searches

    thanks

    Originally posted by sathyaram_s
    Please go through the comaptability section of DB2 V8 - what's new before doing any version upgrade

    There is a section on limitations of having the clients and servers, one in 7 and the other in 8, in the same document ..

    HTH

    Cheers

    Sathyaram

  4. #4
    Join Date
    Mar 2003
    Posts
    33

    Re: blob selection problems

    "To avoid the known restrictions and limitations, you should migrate all of your servers to Version 8 before you migrate any of your client machines to Version 8. If this is not possible, then you should know that when accessing Version 7 servers from Version 8 clients, there is no support available for:
    Some data types:
    Large object (LOB) data types. .... "

    (http://www-3.ibm.com/cgi-bin/db2www/...n=c0005148.htm)
    -r-

  5. #5
    Join Date
    Mar 2003
    Posts
    5

    Re: blob selection problems

    Thank You very much




    Originally posted by raisa
    "To avoid the known restrictions and limitations, you should migrate all of your servers to Version 8 before you migrate any of your client machines to Version 8. If this is not possible, then you should know that when accessing Version 7 servers from Version 8 clients, there is no support available for:
    Some data types:
    Large object (LOB) data types. .... "

    (http://www-3.ibm.com/cgi-bin/db2www/...n=c0005148.htm)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •