Results 1 to 6 of 6
  1. #1
    Join Date
    Mar 2003
    Posts
    11

    Wink Unanswered: cannot create innodb tables

    I have been trying to build tables as innodb with no luck

    platform - win2k 1ghz 512mb Ram
    my.ini file C:/winnt
    [WinMySQLAdmin]
    Server=C:/mysql/bin/mysqld-max-nt.exe
    innodb_data_home_dir = c:\mysql\data
    innodb_data_file_path=C:\mysql\data:250M:autoexten d

    as per suggestions I have tried "\" and "/" in my.ini file.

    mysql-max is running as a service, installed from compiled .zip file, not binaries.

    tables are built with type=InnoDB;

    but no matter what I do, the have_innodb variable is "DISABLED". and innodb_data_file_path is "", and innodb_home_dir is also "".

    Strangely, although BerkleyDB is not supposed to be included in Windows versions, my variables state that Berkley version 3.2.9a is available.

    Any help would be appreciated.

    Simon
    Last edited by simetz; 03-31-03 at 01:23.

  2. #2
    Join Date
    Jan 2003
    Location
    Paris, France
    Posts
    320

    Re: cannot create innodb tables

    Originally posted by simetz
    I have been trying to build tables as innodb with no luck

    platform - win2k 1ghz 512mb Ram
    my.ini file C:/winnt
    [WinMySQLAdmin]
    Server=C:/mysql/bin/mysqld-max-nt.exe
    innodb_data_home_dir = c:\mysql\data
    innodb_data_file_path=C:\mysql\data:250M:autoexten d

    as per suggestions I have tried "\" and "/" in my.ini file.

    mysql-max is running as a service, installed from compiled .zip file, not binaries.

    tables are built with type=InnoDB;

    but no matter what I do, the have_innodb variable is "DISABLED". and innodb_data_file_path is "", and innodb_home_dir is also "".

    Strangely, although BerkleyDB is not supposed to be included in Windows versions, my variables state that Berkley version 3.2.9a is available.

    Any help would be appreciated.

    Simon

    First you need to include innodb variable in [mysqld] section and not in [winmysqladmin]

    it look like
    innodb_data_file_path = file1:size1;....
    innodb_data_home_dir = x:\.....
    innodb_log_group_home_dir = x:\.....
    innodb_log_arch_dir = x:\.....
    set-variable = innodb_mirrored_log_groups=X
    set-variable = innodb_log_files_in_group=X
    set-variable = innodb_log_file_size=XM
    set-variable = innodb_log_buffer_size=XM
    innodb_flush_log_at_trx_commit=1
    innodb_log_archive=0


    Note that MySql will not create any folder you must create this folder before.

    Note You may not put data in c:, you may use an other partition
    Olivier Miossec
    --
    http://www.lasso-developpeur.net/
    --

  3. #3
    Join Date
    Mar 2003
    Posts
    11

    Re: cannot create innodb tables

    Are you stating that if my drive is not partitioned, I cannot use innodb tables??


    Originally posted by omiossec
    First you need to include innodb variable in [mysqld] section and not in [winmysqladmin]

    it look like
    innodb_data_file_path = file1:size1;....
    innodb_data_home_dir = x:\.....
    innodb_log_group_home_dir = x:\.....
    innodb_log_arch_dir = x:\.....
    set-variable = innodb_mirrored_log_groups=X
    set-variable = innodb_log_files_in_group=X
    set-variable = innodb_log_file_size=XM
    set-variable = innodb_log_buffer_size=XM
    innodb_flush_log_at_trx_commit=1
    innodb_log_archive=0


    Note that MySql will not create any folder you must create this folder before.

    Note You may not put data in c:, you may use an other partition

  4. #4
    Join Date
    Sep 2002
    Location
    Montreal, Canada
    Posts
    224
    Provided Answers: 1

    Re: cannot create innodb tables

    Originally posted by simetz
    I have been trying to build tables as innodb with no luck

    platform - win2k 1ghz 512mb Ram
    my.ini file C:/winnt
    [WinMySQLAdmin]
    Server=C:/mysql/bin/mysqld-max-nt.exe
    innodb_data_home_dir = c:\mysql\data
    innodb_data_file_path=C:\mysql\data:250M:autoexten d

    as per suggestions I have tried "\" and "/" in my.ini file.

    mysql-max is running as a service, installed from compiled .zip file, not binaries.

    tables are built with type=InnoDB;

    but no matter what I do, the have_innodb variable is "DISABLED". and innodb_data_file_path is "", and innodb_home_dir is also "".

    Strangely, although BerkleyDB is not supposed to be included in Windows versions, my variables state that Berkley version 3.2.9a is available.

    Any help would be appreciated.

    Simon
    Always had problem with that stuff on Windows and was able to make it work by putting double "\" . Here's a section of my my.cnf file:

    innodb_data_file_path = tablespace_01:1024M:autoextend
    innodb_data_home_dir=C:\\Prog\\MySQL4\\innodb\\tab lespaces
    innodb_log_group_home_dir = C:\\Prog\\MySQL4\\innodb\\logs
    innodb_log_arch_dir = C:\\Prog\\MySQL4\\innodb\\logs

    Hope this helps.

  5. #5
    Join Date
    Jan 2003
    Location
    Paris, France
    Posts
    320

    Re: cannot create innodb tables

    Originally posted by simetz
    Are you stating that if my drive is not partitioned, I cannot use innodb tables??
    No it is just a suggestion.
    YOu may use a no system partition to store data.
    Olivier Miossec
    --
    http://www.lasso-developpeur.net/
    --

  6. #6
    Join Date
    Jan 2003
    Location
    Paris, France
    Posts
    320

    Re: cannot create innodb tables

    Originally posted by bstjean
    Always had problem with that stuff on Windows and was able to make it work by putting double "\" . Here's a section of my my.cnf file:

    innodb_data_file_path = tablespace_01:1024M:autoextend
    innodb_data_home_dir=C:\\Prog\\MySQL4\\innodb\\tab lespaces
    innodb_log_group_home_dir = C:\\Prog\\MySQL4\\innodb\\logs
    innodb_log_arch_dir = C:\\Prog\\MySQL4\\innodb\\logs

    Hope this helps.
    With Mysql Max and MySql 4 on win 2000
    you could use x:\....\...
    without trouble
    Olivier Miossec
    --
    http://www.lasso-developpeur.net/
    --

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •