Results 1 to 15 of 15
  1. #1
    Join Date
    Apr 2003
    Posts
    14

    Unanswered: informix connectivity problems

    l have installed informixSE7.2 on a linux box (redhat 7.2).
    Updated the /etc/hosts, /etc/service files and sqlhosts files


    started the sqlexecd to accept remote connections.

    Create the demo database and used dbaccess to make sure it worked

    Then l installed InformixClient on a windows machine.
    Update my /etc/hosts, /etc/service files and sqlhosts files
    Set my env variables using Setne32

    When l use the DBPing utility to test a connection the informix service on remote machine dies
    and l get a error number 908


    Could somebody help me.

  2. #2
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534

    Re: informix connectivity problems

    Did you create a connection setting in setnet32?
    Did you define a new host in setnet32?
    What's the protocol U used?

    Did you create a sqlhosts file on the server?

    Normally -908 indicates that there is something wrong with the client or server connection settings.
    It is always possible that your network is indead conjested. Do you currently have network problems?

    What part of DBPING gave the error?
    I-Connect or ODBC?

    What is the value INFORMIXSERVER variable when you use dbping?
    rws

  3. #3
    Join Date
    Apr 2003
    Posts
    14
    I created the connection settings and defined a new hosts in setnet32
    The protocol is sesoctcp.

    I edited the sqlhost file on the server, the following was added
    informix_se sesoctcp one4all-redsrv.uk.one4alltechonologies.com informix_service

    The network is fine.

    The I-Connect and ODBC part of DBPing was used to a test connection.

    The value of INFORMIXSERVER is informix_se
    Last edited by mohammed; 04-02-03 at 08:34.

  4. #4
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    are you able to connect with dbaccess (connection tab) using the tcp connection (informix_se) without providing a username/password?
    any errors in the log file?

    How did you define your host on the client? IP or name?
    Could you check how it works with IP?
    rws

  5. #5
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    What is the exact port number you used?
    It seems some Linux machines have problems with low port numbers. Could you try it with f.ex. port: 8888/tcp ?
    rws

  6. #6
    Join Date
    Apr 2003
    Posts
    14
    Originally posted by Roelwe
    What is the exact port number you used?
    It seems some Linux machines have problems with low port numbers. Could you try it with f.ex. port: 8888/tcp ?
    I am able to connect with dbaccess without a username/passwd, there are no errors in logfile.

    I have just tried connecting with IP addess

    l have also tried with a higher number port i.e 8888 and 50002

    but to no avail.


    My setting are as follows
    Server Machine
    <1> /etc/hosts = 10.0.0.16 one4all-redsrv.uk.one4alltechnologies.com one4all-redsrv

    <2> /etc/services = informix_service 50002/tcp

    <3> $INFORMIXDIR/etc/sqlhosts =
    informix_se sesoctcp one4all-redsrv.uk.one4alltechnologies.com informix_service

    <4> Env variables:
    INFORMIXDIR = /opt/informixSE7.2
    PATH = $INFORMIXDIR/bin
    LD_LIBRARY_PATH=$INFORMIXDIR/lib
    INFORMIXSERVER = informix_se
    DBPATH = /home/mohammed/database_config/informix/stores7

    Client Machine
    <1> /etc/hosts = 10.0.0.16 one4all-redsrv.uk.one4alltechnologies.com one4all-redsrv

    <2> /etc/services = informix_service 50002/tcp

    <3> $INFORMIXDIR/etc/sqlhosts =
    informix_se sesoctcp one4all-redsrv.uk.one4alltechnologies.com informix_service

    <4> Env variables:
    INFORMIXDIR = C:\Program Files\Informix\Client-SDK
    PATH = $INFORMIXDIR/bin
    LD_LIBRARY_PATH=$INFORMIXDIR/lib
    INFORMIXSERVER = informix_se
    DBPATH = /home/mohammed/database_config/informix/stores7

    After l start informix_se, l can see that the informix_service is in a listen state
    netstat -l -t --numeric-ports -e -e

    but as soon as l try to connect via DBPing the informix_service dies

  7. #7
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    how did you start the sqlexec daemon?
    rws

  8. #8
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Did you setup your hosts.equiv file?
    rws

  9. #9
    Join Date
    Apr 2003
    Posts
    14
    Originally posted by Roelwe
    how did you start the sqlexec daemon?

    Logged on as root
    set all env variables

    $INFORMIXDIR/lib/sqlexecd informix_se -l logfile

    l did not setup the host.equiv file
    as there is no file on the remote machine

    Although l did edit the .rhost file in my home directory as follows
    one4all-mo mohammed
    one4all-mo.uk.one4alltechnologies.com mohammed
    Last edited by mohammed; 04-02-03 at 10:09.

  10. #10
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    This file has to be create by root in the /etc directory.
    What happens if you put a + on the first line, followed by a blank line?
    rws

  11. #11
    Join Date
    Apr 2003
    Posts
    14
    Originally posted by Roelwe
    This file has to be create by root in the /etc directory.
    What happens if you put a + on the first line, followed by a blank line?
    by creating the hosts.equiv file, the informix_service still crashes

  12. #12
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Little bit stuck here...

    Did you check the release notes? $INFORMIXDIR/release/*/*/

    Might be a problem that this kernel is not supported for that version of SE.
    Check the machine notes for the supported kernel version and supported version of glibc.

    What is the version of the SE engine?

    bcheck -V

    Are you sure the variable INFORMIXSQLHOSTS is not set?

    What version of client software do you use?
    rws

  13. #13
    Join Date
    Apr 2003
    Posts
    14
    Originally posted by Roelwe
    Little bit stuck here...

    Did you check the release notes? $INFORMIXDIR/release/*/*/

    Might be a problem that this kernel is not supported for that version of SE.
    Check the machine notes for the supported kernel version and supported version of glibc.

    What is the version of the SE engine?

    bcheck -V

    Are you sure the variable INFORMIXSQLHOSTS is not set?

    What version of client software do you use?
    l have checked the release notes, every thing seems fine

    The SE version is
    C-ISAM Version 7.24.UC5

    l have tried various clients SDK
    2.1, 2.4, 2.81

  14. #14
    Join Date
    Apr 2003
    Posts
    14
    Hello Roelwe,

    l thank you for the effort and I appreciate all the help.

    regards.

  15. #15
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    I am sorry I couldn't be of any more help. I think something must have went wrong somewhere.

    Maybe a reinstallation of the software would help... dunno.
    rws

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •