Results 1 to 8 of 8

Thread: err = -25574

  1. #1
    Join Date
    Apr 2003
    Posts
    3

    Unanswered: err = -25574

    I ask for help for the following problem:

    The last line of the "onstat -u" shows three things:
    active xx, total xx, maximum concurrent xx
    when this line looks like this: "98 active, 128 total, 98 maximum concurrent", a new user can not login and the following errorcode appears:
    "14:31:56 listener-thread: err = -25574: oserr = 24: errstr = : Network driver c
    annot open the network device.
    System error = 24. "

    I tried to change the NETTYPE-parameter already (actual entry: " tlitcp,1,200") - but no success

    Informix-Version is 7.30 UC8
    Thank you for help !

  2. #2
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    Check your kernel parameters, probably the number of open files should be increased.
    Every time you open a new connection, a new 'file' is opened...
    rws

  3. #3
    Join Date
    Apr 2003
    Posts
    3
    Can you tell me the name of the correct kernel-parameter to change the number of files? I don't know exactly, which parameter is the right one (we use SINIX-N 5.43 C 5001 ) .
    Thank you.

  4. #4
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    OK, this is how I got there:

    find / -name errno.h -exec grep "24" {} \;

    #define EMFILE 24 /* Too many open files */
    ...


    The command you are looking for is 'ulimit -n <#openfiles>'
    ulimit -n reports the current number of open files.

    I hav ea redhat and there it is '-n'. It is possible that you have to check your man pages to get the correct argument/flags.
    Once you set this, it is possible you have to reboor your system and restart the informix instance.
    rws

  5. #5
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    OK, this is how I got there:

    find / -name errno.h -exec grep "24" {} \;

    #define EMFILE 24 /* Too many open files */
    ...


    The command you are looking for is 'ulimit -n <#openfiles>'
    ulimit -n reports the current number of open files.

    I hav ea redhat and there it is '-n'. It is possible that you have to check your man pages to get the correct argument/flags.
    Once you set this, it is possible you have to reboor your system and restart the informix instance.
    rws

  6. #6
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    find / -name errno.h -exec grep "24" {} \;
    #define EMFILE 24 /* Too many open files */
    ...

    Action increase number of open files.
    On linux, the command ulimit -n will do the trick. Otherwise, check man pages.
    rws

  7. #7
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    sorry about the double reply. It failed the first time..
    rws

  8. #8
    Join Date
    Apr 2003
    Posts
    3

    Lightbulb

    Thank you very much for your help !

    I never thought about the error Nr. 24. I always looked upon the error-number 25574 ...

    "ulimit -n" was 100 - now I changed it to 256 (it is the kernel-parameter SFNOLIM) and the "maximum concurrent" number of users can rise over 100 - like magic ..

    You helped me very much, thank you again !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •