Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2003

    Unanswered: cannot delete replicate

    here is my problem:
    when i try to delete replicate with:
    cdr delete replicate -c <server> <repl_name>
    it says me that this replicate is not defined and cannot delete it.
    when i run cdr list repl, this replicate i shown in the output and is ACTIVE.
    but this replicate doesn't working cause when i insert into prim server's one replicated table, the inserted row doesn't go to target server -so replication doesn't work. with replication menager under winNT connected to targer server i see both servers,and all replicates between them ACTIVE but when i try to connect to target server it says me:
    The Start of ER on the server g_serv2 failed with error 951[ESQL/Serer error].
    i check the files hosts.equiv on both servers and everything is fine.
    i want to delete replicates betwen two servers, cause i want to delete one of them-g_serv2 , and define it again. what can i do?

  2. #2
    Join Date
    Aug 2002
    I would recommend to work only with the command
    line interface ('cdr') and not with the NT GUI interface.

    It might be that the global cache is not up to date.
    Try to directly login to the machine where this replicate
    is defined and try the delete-command again.
    Altought you might restart ER, so that the global cache
    gets refreshed.

    You might also post this question to the newsgroup comp.databases.informix. This newswgroups is watches
    by some guys from IFMX development directly.

    Best regards

    IT-Consulting Herber

    Download the IFMX Database-Monitor for free at:

  3. #3
    Join Date
    Apr 2003
    thanks a lot. i tried everything you said to me,but nothing helped. finaly i drop all the cdr databases in all servers, delete all servers from replication, and define them again, and everything seems to be fine. i still don't understand what happend

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts