Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2003
    Posts
    12

    Unanswered: Execution plan does not work

    Hi there,

    I am having a problem with the Query analyzer. When I display the execution plan in Query Analyzer on a computer connecting
    to our remote production server it displays 0% cost for _all_ performed tasks. When I execute it locally on that server the cost are displayed correctly.

    Here is a screenshot of the problem : http://www-dev.themeparkvision.net/north.gif

    The problem doesn't manifest itself exlusivly on a remote server. I saw it also localy with the northwind database.
    So if i execute "select * from dbo.Invoices" I get a 0% cost for all the operators. Very annoying.

    A couple of things I investigated :

    1) autocreate statistics and autoupdate stats are enabled for the database

    2) The problem is the same for both estimated and actual execution plan.

    My version of QA on the client is 8.00.760 (SP3) and the server is SQLServer 2000 (Build 2195: Service Pack 2)

    I cant solve this problem no matter what i've tried, pls help

  2. #2
    Join Date
    Apr 2003
    Posts
    12
    Hi all,

    I finaly solved the problem through expert-exchange.com with the help of ispaleny (poinst coming you way. Thanks a lot!)

    It has to do with the reginal settings! Didn't come up with that myself.

    My remote server had English(US) and the local was Belgium. After I changed the local system to English(US) the prob was gone.

    So it is a bug that probably had to do with punctuatuin. Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •