Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2003
    Posts
    23

    Unanswered: Redhat 9 & Informix

    hello

    we're going to contact informix about this -b ut does anyone know if Informix plans a new sdk release that works with redhat 9? Currently the glibc in rh9 is not compatible with the 2.81 sdk.

    Currently the only solution we have that will work is to take the patches rh applied to glibc in rh8 and apply to rh9 and rebuild the glibc rpms.

    anybody else bitten by this?

  2. #2
    Join Date
    Dec 2002
    Location
    Portland, OR, USA
    Posts
    26

    Red Hat and Informix SDK

    I can't help you directly, but I can prepare you for what to expect from Informix in this regard: Very little, unless you want to pay for it. We ran into the same problem with Red Hat 7.3, which ships with gcc 2.96

    Informix claimed compatibility with a variety of Red Hat releases, including 7.3, but then it turned out that the part of the SDK we were interested in (support for a little obscure language called C++) was actually incompatible with gcc 2.96. Rather than privately fund a patch solution, we turned to RogueWave SourcePro, which uses the same API as the ODBC layer, and have had some success there.

    Multi-thread safety is critical to us- I am not sure what requirements are driving you, but at least this may be an option.

    A caveat for any of the SDK's is: try to get all of your requirements fleshed out up front. We have RogueWave isolated inside our data tier in order to manage the cost of developer seats, and now we have some compatibility issues between it and the multi-thread STL we selected early on for the entire project team (STLport). We're still trying to work through that, so if you have similar concerns, ask questions early on, and get answers in writing.

  3. #3
    Join Date
    Jan 2003
    Posts
    23
    We have a support contract, but we figured it would take informix forever to do anythign about it, so I fixed the glibc incompatibility... so we're all set now.

    thanks.

  4. #4
    Join Date
    Jun 2003
    Location
    toulouse
    Posts
    2
    did you get other errors with your glic fixed ?

    Because I have had the same problem with RH9 and I have decided to go back to RH 7.3 which works fine with informix SDK.

  5. #5
    Join Date
    Jan 2003
    Posts
    23
    It worked fine...
    but we decided to just switch to RH8 with a new kernel so we wouldn't have to deal with any other support issues, etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •