Results 1 to 6 of 6
  1. #1
    Join Date
    Apr 2003
    Posts
    2

    Unanswered: Sql Server and Windows Server 2003

    Hello,

    I was doing same google and then i find this forum and start reading same posts, and i know that is not very decent start the first post asking for help, but here it goes:

    The Problem that i have is that i can't install SQL 2000 Server Enterprise Edition SP3 on Windows Server 2003 Enterprise Edition/3790.

    I know what is causing the problem but i don't know how to solve it, the problem is that the OS is blocking the SQL ports, why ?, see this extraction from the Event Viewer:

    ----------------------------Event ID 1-----
    You are running a version of Microsoft SQL Server 2000 or Microsoft SQL Server 2000 Desktop Engine (also called MSDE) that has known security vulnerabilities when used in conjunction with the Microsoft Windows Server 2003 family. To reduce your computer's vulnerability to certain virus attacks, the TCP/IP and UDP network ports of Microsoft SQL Server 2000, MSDE, or both have been disabled. To enable these ports, you must install a patch, or the most recent service pack for Microsoft SQL Server 2000 or MSDE from http://www.microsoft.com/sql/downloads/default.asp

    -----------------------------Event ID19011----

    SuperSocket info: (SpnRegister) : Error 1355.

    ---------------------------------------------------

    Then when i try to install the SP3, it want work because the setup can't connect to SQL Server, because the comunications ports are disable by the OS.

    ----------------Extracted from the sqlsp.log-----------

    09:46:23 Process Exit Code: (1)
    09:47:08 Begin SDPassword Dialog
    09:47:09 End SDPassword Dialog
    09:47:09 E:\x86\BINN\osql.exe -Slpc:ALEXNET -n -d master -Q "exit" -o "C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\sqlsp.out" -E
    09:48:23 Process Exit Code: (1)
    09:48:43 C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\SqlSetup\Bin\sc m.exe -Silent 1 -Action 6 -Service MSSQLSERVER
    09:49:13 Process Exit Code: (0)
    09:49:17 Setup was unable to verify the state of the server for an upgrade. Verify the server is able to start and that you provided a valid sa password and restart setup.
    09:49:19 End Action DialogShowSdUpgrade
    09:49:19 End: ShowDialogs()
    09:49:19 Action CleanUpInstall:
    09:49:19 Installation Failed.

    ------------------------------------------------------

    So my question is how do i enable this ports at the OS, or change the rule that prevent the SQL Server from running???

    Thanks for Helping me.,

    Alex
    Last edited by alex3299; 04-29-03 at 06:31.

  2. #2
    Join Date
    Feb 2002
    Location
    Houston, TX
    Posts
    809
    Could you set up a Multiprotocol or Named Pipes connection and then do the install/upgrade?
    Paul Young
    (Knowledge is power! Get some!)

  3. #3
    Join Date
    Jan 2003
    Location
    dublin, Ireland
    Posts
    6
    This is proably nothing to do with it but have you tried disconnecting from the web\network b4 installation as it may be something to do with the slammer virus that sp3 deals with, I am just mentioning it as I had no such problem installing sql sp3 on enterpirise sql for win2003 enterprise edition.

  4. #4
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    What is the authentication mode used to connect?
    Moreover SQL Server 1355 Warning Errors are Informational.
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

  5. #5
    Join Date
    Apr 2003
    Posts
    2
    Thanks for the Help.

    Was for the connection, it's doesn’t work I tried to change the ports and using multiprotocol's nothing work, every time I got the same error the setup can't connect to SQL Server.

    I'm using Mixed Mode to connect to the server, and I have a big password, but neither of the authenticate methods work, but for example if I put a website on port 1433 the port work, but every time I change the ports on SQL the OS knows it and block it, I install it on all this beta versions (RC1,RC2,3769) the same way and it work's ok, now that I have the RTM it's doesn’t work anymore...

    I'm pretty sure that I can fix this just deleting or changing a key on the registry the problem is to know what key is, I never tried to install it off-line because I think it won't work, like that the setup will fail because it don't start the service....

  6. #6
    Join Date
    Aug 2002
    Location
    Scotland
    Posts
    1,578
    Refer to this MSDN Link about Registry entries for netlibs after SQL installation.

    HTH
    --Satya SKJ
    Microsoft SQL Server MVP
    [IMG]http://sqlserver-qa.net/google_bart.gif[/IMG]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •