Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2003

    Angry Unanswered: Random Error when downloading data...

    Hi All,

    OK - I have no idea how to start to explain this goes...

    Currently working on a database that downloads data from a Bloomberg terminal - the download function has been written and tested and works EXCEPT for the following: Tried to download 19645 records - only 19635 records were retrieved. Tried to download 18000 records - only 17990 records were retrieved etc ec. Basically, the download runs fine but retrieves 10 records less than expected - however, this error only seems to occur with very large numbers, when tested with 2556 records it works fine every time...??? It is as if Access is holding the last 10 records in memory somewhere - when the module is run again it 'flushes' out these last records and suddenly there are only 10 records in the download...
    The 'records retrieved' number has to be exactly as expected for other processes to start running in the database - rather crucial then that I figure this out!
    Anyone out there ever had a similar type of error? Is there some limit to what Access can hold in 'virtual memory' before generating errors?
    Sorry that this is all a bit vague, I'll be grateful for any ideas thrown my way, not even sure where to start at the moment...

    Cheers all


  2. #2
    Join Date
    Dec 2002
    Glasgow, UK
    It might be something to do with "Allow zero length" in the fields?

  3. #3
    Join Date
    Mar 2003
    No, unfortunately not. The reason I though it might have something to do with the memory getting 'confused' is that the data is read into the table in sets of 10 records at a time from seems as if the database randomly 'forgets' 10 records..and then, sometimes it doesn''s a complete mystery to me...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts