Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2003
    Posts
    1

    Unanswered: XP PC Runs slow with Foxpro 2.6 minimized

    Hi All,

    Setup :
    Compaq Desktop, P4 1.6 , 128mb Ram, Win XP Pro, NAV 7.6

    When running the Foxpro application everyting works fine. The problems start when the application is minimized and the user attempts to open other apps e.g. word , excel etc etc.

    These applications run very slowly, close the foxpro app and everything runs normally.

    I've tried usign the run in own memory space, adjusting the priority of NTDM, using the different compatability options. So far nothing has helped.

    The high speed cpu patch has been installed.

    I've checked task manager during the slow down and found fp26000.esl pretty much at 100% CPU utilisation.

    Testing has been done with the application running locally and across the network.

    Any help would be greatly appreciated.

    Bryan Tabb

  2. #2
    Join Date
    Jul 2003
    Posts
    2
    Go to www.tamedos.com and download the application. The CPU usage will be 1-3% instead 90-100% for DOS application under Windows 2k/XP

  3. #3
    Join Date
    Sep 2003
    Location
    Sacramento, CA
    Posts
    28

    Re: XP PC Runs slow with Foxpro 2.6 minimized

    I am not sure about Foxpro but I know Clipper has a similar problem with this because Clipper constantly polls the keyboard for input causing the CPU utilization to shoot up to 100%. There are quite a few tools out there to fix this polling. We use Tamedos also but for a different reason than the polling. You might try Tamedos though.

    David


    Originally posted by bryan.tabb
    Hi All,

    Setup :
    Compaq Desktop, P4 1.6 , 128mb Ram, Win XP Pro, NAV 7.6

    When running the Foxpro application everyting works fine. The problems start when the application is minimized and the user attempts to open other apps e.g. word , excel etc etc.

    These applications run very slowly, close the foxpro app and everything runs normally.

    I've tried usign the run in own memory space, adjusting the priority of NTDM, using the different compatability options. So far nothing has helped.

    The high speed cpu patch has been installed.

    I've checked task manager during the slow down and found fp26000.esl pretty much at 100% CPU utilisation.

    Testing has been done with the application running locally and across the network.

    Any help would be greatly appreciated.

    Bryan Tabb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •