Hi,

I'm trying to use XA resources with Oracle. I use the demo db setup during installation, it works fine, but when I try to create my own db using sqlplus, I get this error:

oracle.jdbc.xa.OracleXAException
at oracle.jdbc.xa.OracleXAResrouce.checkError(OracleX AResource.java:1157)
at oracle.jdbc.xa.client.OracleXAResource.start(Oracl eXAResource.java:295)
at XA.main(XA.java:70)

There are no oracle errors in rdbms/logs.

Here's the gist of the db I'm creating:
sqlplus << EOT
Connect / as sysdba
shutdown abort
startup pfile=$ORACLE_HOME/dbs/p_create_xadb.ora nomount

create database xadb
controlfile reuse
datafile '/data/sys_xadb' size 150M reuse
undo tablespace undotbs datafile '/data/undotbs_xadb' size 100M reuse
autoextend on next 5120 maxsize unlimited
logfile '/data/log1_xadb' size 400M reuse,
logfile '/data/log2_xadb' size 400M reuse
maxdatafiles 100;
exit

then I run these catalog scripts as sysdba
catalog, catexp, catldr, catproc, utlmontr. I've also tried running xaview as sys, but that didn't help either.

Any help much appreciated

-ilean