Results 1 to 8 of 8
  1. #1
    Join Date
    May 2003
    Posts
    2

    Unanswered: Database does not mount automatically @ startup

    I m really new to Oracle so pls be patient with me askin this ques probably u may hav seen a thousand times...

    I installed Oracle 8i and setup a new database. The problem is that this database does not automatically startup (mount) after I reboot the Win2k Adv Server ... I hav to log in as Sysdba and startup the instance manually ...

    Can anyone help me with this? Thanks a million!

    Pixie

  2. #2
    Join Date
    Nov 2002
    Location
    Desk, slightly south of keyboard
    Posts
    697
    Hi Pixie,

    Go to ControlPanel->Adminstrativetools->Services.

    Scroll down to find the service named OracleService<instancename>. Right click, select properties and set startup type to automatic.

    HTH
    Bill

  3. #3
    Join Date
    Apr 2003
    Posts
    15
    Hi Pixie,

    If the billm's suggestion doesn't work, Just comment the following line in the /$ORACLE_HOME/network/admin/sqlnet.ora and restart the server.

    #SQLNET.AUTHENTICATION_SERVICES= (NTS)

    Chenna

  4. #4
    Join Date
    Mar 2003
    Location
    Bangalore
    Posts
    14
    Hi the database doesn't start automatically after a reboot then 9out of 10 times the service is not automatic.coz the instance is binded to the service.If it doesn't work even after making the service automatic,u might probably need to edit the registry to make the startup paramerte auto.i will let u know the parameter if u require.

    Hi chenna,
    i didn't understand how
    If the billm's suggestion doesn't work, Just comment the following line in the /$ORACLE_HOME/network/admin/sqlnet.ora and restart the server.

    #SQLNET.AUTHENTICATION_SERVICES= (NTS)

    this is going to solve the problem.can u explain
    Cheers
    Murali

  5. #5
    Join Date
    Apr 2003
    Posts
    15

    Smile

    Hi murali,
    What I understood from the problem : Pixie just installed oracle8i. So, there could not be any problem with oracle registry settings. There could be problem with one of the management files.
    Actually, I forgot to ask pixie which version of oracle he is using. My suggestion was for oracle 8.1.7(win2k). It has some problem with sqlnet.ora.

    Chenna

  6. #6
    Join Date
    Mar 2003
    Location
    Bangalore
    Posts
    14
    Hi chenna,

    i had the same problem with 8.1.7 on win2k server.
    Actually there is a startup parameter for database.by default it is manual.unless specified at the instance creation time.my understanding or the sqlnet.ora is for authentication from clients .i have not come across this file in any manuals when the database startup or instance start is referred.so i was just qurious.any further information u can share is welcome.

    Thanks
    Cheers
    Murali

  7. #7
    Join Date
    May 2003
    Posts
    2
    Thanks everyone for your response.

    My oracle version is 8.1.7(win2k). I aleready set the DB instance service to startup automatically but still doesn't work. Will try out the suggestion to comment out line. Thanks!

  8. #8
    Join Date
    Jul 2009
    Posts
    1
    I had the same problem of the database not mounting and opening after a reboot with Oracle 10g. I finally figured out the problem and solution.

    The startup of the database requires access to the pfile. I choose not to have the pfile in the default location under the Oracle Home. Therefore although the service OracleServiceSID started, it could not auto start the database.

    You can specify an alternate location for the pfile when creating the service.

    Oradim -new -sid SID -startmode auto -pfile C:\mypath\InitSID.ora

    To correct the problem I had to tell the service where my pfile is. That is done in the registry at LOCAL_MACHINE/Software/Oracle/KEY_OraDb10g_home1. I had to create a string registry value called ORA_SID_PFILE, where SID is my Oracle SID. The value of the registry setting is the full path of pfile.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •