Results 1 to 3 of 3
  1. #1
    Join Date
    May 2003

    Unanswered: how to install locale codesets ?

    After installing ODBC driver......

    I am a newbee to this, I would like to know exactly how to install local codesets on a client computer(excuse me if it is a stupid question, but please try to be specific...)

    I'm trying to configure a ODBC system DNS connection on a win XP computer, and recive this when I try the connection
    Test Connection was NOT successful. [Informix][Informix ODBC Driver]Unable to load translation DLL.
    I asume the problem is located at the client computer, due to lack of installed codesets

    When I try to change the locate settings I get this
    The displayed locale and codeset have not been found on the local client machine. Using these local/codeset will result in -23101 Unable to load locale categories error message. PLease install the locales

    witch I guess is the true problem, the client machine is as said a winXP computer, and is a danish version.

    should I try with another DNS locale than
    (I have a similar machine witch is working, and on this the DNS locale setting is also set to en_US.CP1252)

  2. #2
    Join Date
    May 2003
    sorry for taking your time (if any)
    I did found the solution in other threads, the problem is not missing locale codesets, it was related to the missing enviroment variable not being set......

    INFORMIXDIR was missing, after putting this in, it works

  3. #3
    Join Date
    May 2003


    A user have ask what the solution was, this is taken from another thread (in here)

    An invalid locale name was supplied for the locale initialization. The
    environment variable to specify the locale category has a wrong value. Check the value of the corresponding environment variable, CLIENT_LOCALE or DB_LOCALE.
    Also check if INFORMIXDIR points to a valid directory where Informix products
    are installed.
    the enviroment variable can be controlled by opening a command promth, and type SET
    this will display all enviroment variables pressently active.

    if the INFORMIXDIR is not listed, it is proberly missing from your autoexec.bat, it should look like
    INFOMIXDIR =C:\informix
    or simmilar, the path can also be entered as a regular "path"
    PATH = c:\informix

    after changeing this, you need to restart the computer
    hopes this helps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts