Results 1 to 3 of 3
  1. #1
    Join Date
    May 2003
    Posts
    2

    Unanswered: sp_grantlogin issue

    I have developed a migration utility for a company with several dealer and there is a few place where it fails while granting the IUSR and IWAM users for a specific database. Here is a log from one of that:

    >Running on Window2000 with Service Pack 3.0
    >Computer Name : C00021
    >Current user : Administrator
    >
    >Available users :
    >Administrator Enabled Admin
    >Gast Disabled User
    >TsInternetUser Enabled User
    >...
    >...
    >...
    >IUSR_C00021 Enabled User
    >IWAM_C00021 Enabled User
    >
    >Current Logins :
    >sa
    >VORDEFINIERT\Administratoren
    >
    >Granting Result:
    >IWAM User Name : IWAM_C00021
    >
    >Executing : EXEC sp_grantlogin N'C00021\IWAM_C00021'
    >Connection Result : Der Windows NT-Benutzer oder die -Gruppe 'C00021\IWAM_C00021' wurde nicht gefunden. Überprüfen Sie den Namen.

    The err itself is German and it means that 'C00021\IWAM_C00021' is not found, while it is there as the previous lines say...

    Is here anybody who has faced this kind of problem with succes?

    Thanks in advance

    HuTT

  2. #2
    Join Date
    May 2003
    Posts
    12
    It works for me.

    Your SQL Server seems to be setup as case sensitive. Check your collation.

  3. #3
    Join Date
    May 2003
    Posts
    2
    I have missed some useful information:
    The platforms are NT4 with sp6 or 2K with sp3 with a brand new MSDE by default settings and NT authentication only.

    btg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •