Results 1 to 5 of 5
  1. #1
    Join Date
    May 2003
    Posts
    60

    Unanswered: Informix I-Connect, DBPing, ODBC Problems

    I've got

    $INFORMIXDIR/etc/sqlhosts

    ol_wgs oltlitcp localhost sqlturbo
    ol_wgs_shm olipcshm localhost srv_agent

    /etc/services

    sqlturbo 1526/tcp
    srv_agent 1530/tcp

    netstat -an|grep 1526
    tcp 0 0 127.0.0.1.1526 *.* CLOSED
    tcp 0 0 127.0.0.1.1526 *.* LISTEN

    no error messages on online.log
    $INFORMIXSERVER on client is ol_wgs

    I have SCO SQL retriever working but just can't get the Informix Client ODBC to work.
    I get a -908 error
    I cannot telnet the listening port either.

  2. #2
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    I would advise yo to change the tcp connection settings in you sqlhosts file.

    Don't use localhost for tcp connections. Use the hostname or ip address.
    This is the hostname where the poll thread will listen.

    Change this and you will be able to connect
    rws

  3. #3
    Join Date
    May 2003
    Posts
    60
    If I change that will I need to just restart informix or tcp/ip aswell?

    Regards

    Paul

  4. #4
    Join Date
    Aug 2002
    Location
    Belgium
    Posts
    534
    I think you do.
    probably.
    rws

  5. #5
    Join Date
    May 2003
    Posts
    60
    many thanks will try this after hours, tonight

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •