Results 1 to 3 of 3
  1. #1
    Join Date
    May 2003
    Location
    USA
    Posts
    3

    Unhappy Unanswered: Crystal With MSDE..>HELP!!

    I get "Unable to Open Database" when I try to run Crystal Reports with MSDE. Any ideas.
    The reports work fine with SQL Server and MS Access.

    Thanks in Advance.

  2. #2
    Join Date
    Apr 2003
    Location
    SC, USA
    Posts
    51
    I'd need more information before I can offer advice.

    How is security set up? Integrated, SQL Server?

    Using OLEDB or ODBC?

    What version of Crystal? MSDE? Are both on the same computer or is access across a network?

    etc...

  3. #3
    Join Date
    May 2003
    Location
    USA
    Posts
    3

    Unhappy MSDE with Crystal Reports--A Real Challange

    Thanks for your reply,

    I am using MSDE 1.0(SQL Server 7.0) and Crystal Reports Version 8.5. The application that runs the reports is on the same machine as the database for now. I am using ADO (MDAC 2.7) to connect to the database.

    The reports are made off a MS Access Database (2000) and I change the driver at run time, as it checks for the database type that the application is running off of. I am using:

    Crpe.Tables.ConvertDriver(pssql.dll)

    function to convert the driver from Access to SQL Server.

    Once I try to run the reports it gives me Crystal Report
    [error 533:Unable to Open Database]

    But once I run the same reports on MS SQL Server or MS Access Database it works fine or even once I run these reports off of MSDE running on XP Professional it still works fine.

    This has become a real chanllenge. Any help would be appreciated.

    THANKS IN ADVENCE.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •