Results 1 to 4 of 4
  1. #1
    Join Date
    May 2003
    Posts
    1

    Post Unanswered: Access XP to 97 Switchboard conversion problem

    Hello,

    I have converted a database that I have created in Access XP to Access 97. I have fixed all problems except for the Switchboard. When i try to access the switchboard it gives me the following error:

    "Compile Error: User-defined type not defined"

    this error is coming up int he FillOptions() function and the following line is highlighted:

    "Dim dbs As Database"

    I've also tried deleting the old switchboard and creating a new one in 97 but I get the same error.

    I'm pretty sure it's a driver issue but haven't been able to figure it out.

    Thanks in advance.
    Thai

  2. #2
    Join Date
    Aug 2004
    Posts
    2

    Switch Board Access 97 error

    I am experiencing the exact same error as you. I have recreated the entire swithboard.. it works for some days... till a new user goes in and then I start getting the errpr again. Can someone please help!

  3. #3
    Join Date
    Feb 2004
    Location
    Chicago, IL
    Posts
    1,312
    Make sure you have reference to DAO and try putting DAO. in front of Database. Like:

    Dim dbs As DAO.Database

  4. #4
    Join Date
    Aug 2004
    Posts
    2

    Switchboard Access 97 XP problem solved

    Thank you thank you thank you.... Proverbially eternally grateful. This solution worked for me...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •