Results 1 to 5 of 5

Thread: Lock_timeout

  1. #1
    Join Date
    Apr 2003
    Posts
    9

    Unhappy Unanswered: Lock_timeout

    Hello,

    in EM (SQL7) i got the following errormessage, when i click on
    current activity:

    "Error: 1222 lock request time out period exceeded"


    I run the sp_who /sp_who2, but nothing is blocked.

    I set the lock_timeout th 5000, but it does not help.


    Does anyone have an idea ?

    best regards

    Martin

  2. #2
    Join Date
    May 2003
    Location
    Athens Greece
    Posts
    13
    network traffic is an idea
    try to change for instance from tcp/ip to netbeui, or vice versa as the protocol you use to connect to the db server
    see what happens.

    also try to run a performance monitor to the db server.

    check for cpu usage and latches.

    if avg.latch wait time is high, ie. over 1000 and total latch wait time is also high i.e. over 100 for instance, then you probably experience sql server locks (watch for lock timeout /second)....

    this can mean that the server is small, the app is poor, problem with your net h/w...

    but this is some place to start with...

    Cheers.

  3. #3
    Join Date
    Apr 2003
    Posts
    9

    Angry

    Thanks for help Arounis,

    network traffic is not possible, because i can log on to the server an got
    the same error message.

    For remember: I only get the error message, when i click on current activity in EM. No User told me that a problem still exits.

    Checking avg.latch time and total latch time results:

    520 constant for avg latch time

    0 - 16 for total latch time.

    You don't think that the problem occours about a "user - transaction" ?

    Martin

  4. #4
    Join Date
    May 2003
    Posts
    22
    Try seeing if there is a locked resource which doesn't have a corresponding entry in sysprocesses

    select *
    from master..syslocks a
    left join master..sysprocesses b on a.spid = b.spid
    where b.spid is null

    You shouldn't get any results.
    Don't know what to tell you if you get any results.

  5. #5
    Join Date
    Apr 2003
    Posts
    9
    Thanks Wilso_s, but i get no results.

    One more detail i detected, is that i can't access the
    tempdb in EM. EM hangs up.

    This short KB artikel Q308518 describes problems with
    tempdb, but there is no workaround.

    Maybe a restart will help ?

    Thnx

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •