Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2003

    Red face Unanswered: SQL*plus behaviour with Japanese data

    This is a typical problem I have found with the SQL*plus tool. When I am trying to insert Japanese characters into database using an insert script, rows are getting inserted but when we try to retrieve, it is showing JUNK data. My database server and client both are of 8.1.7 version and UTF8 Charset based. NLS_LANG has been set to japanese_japan.ja16sjis.

    To explain clearly, I am saving insert commands script as file1.sql with 'save as type' UTF8 in notepad, with font 'tahoma'. Then I am able to see Japanese chars in script file. When I run this script from SQL*plus as @file1.sql, rows were inserted. I have a JSP file to see the output of query, through browser. When I quried this table, browser is showing some Junk chars (but looks like Japanese, not exactly). Funnily, when I copy an insert statement alone from script and paste it in SQL*plus window, it is showing evrything correctly except the values in japanese values column. instead it shows ? symbols. I have tried this with other languages like chinese, polish etc. then it worked fine. Do i need apply any fix pack to SQL*plus? or do i need any other settings to do on client m/c side? A quick response is really helpful.

    Thanks in advance


  2. #2
    Join Date
    Jun 2003
    VA, USA

    Re: SQL*plus behaviour with Japanese data

    If your Oracle server's character set was UTF8, then your client computer also have to set as "NLS_LANG=japanese_japan.UTF8" in the registry or environment variable.

    The "NLS_LANG" in registry is used by SQL*NET and it should be same value as your server has.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts