Results 1 to 3 of 3
  1. #1
    Join Date
    Jun 2003
    Posts
    1

    Red face Unanswered: INGRES - Createdb - Database does not exist (isnt that the point?)

    I'm trying to create a database in ingres called refmail, and it says database does not exist and gives abnormal termination.

    I've checked accessdb and there is no such database and everything looks fine, so why wont it create?

    I am doing

    createdb -urefmail refmail

    gives me:

    createdb -urefmail refmail
    Creating database 'refmail' . . .

    E_US0010 Database does not exist: 'refmail'.
    (Sun Jan 26 17:19:21 2003)

    and refmail is a valid user with create database priviledges.
    I've created two other databases with junk names and they work fine! How can I find out why this one wont work?
    Last edited by AmandaAlderman; 06-06-03 at 12:33.

  2. #2
    Join Date
    Jun 2003
    Location
    UK
    Posts
    2

    Re: INGRES - Createdb - Database does not exist (isnt that the point?)

    Originally posted by AmandaAlderman
    I'm trying to create a database in ingres called refmail, and it says database does not exist and gives abnormal termination.

    I've checked accessdb and there is no such database and everything looks fine, so why wont it create?

    I am doing

    createdb -urefmail refmail

    gives me:

    createdb -urefmail refmail
    Creating database 'refmail' . . .

    E_US0010 Database does not exist: 'refmail'.
    (Sun Jan 26 17:19:21 2003)

    and refmail is a valid user with create database priviledges.
    I've created two other databases with junk names and they work fine! How can I find out why this one wont work?

    Are you using the same -u flag, e.g. "-urefmail" with accessdb. If not then the db might not be listed, depending upon who created it and how the access to the DB is set up. Remember that Ingres allows different users to create dbs of the same name.

    If you are using accessdb correctly then it could be a problem with the system catalogues, e.g. you created the DB and the session fell over leaving it in a half complete state. Have you tried deleting the DB using destroydb -urefmail refmail then recreating.

    hth

  3. #3
    Join Date
    Jul 2003
    Posts
    1

    Re:

    May be a little late to this party, since you posted this a month ago, but hey - I just registered. The problems I have had with this error were caused by residual checkpoint / journal files - make sure that there are no transaction logs / general logs etc named after that database too.

    Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •