Results 1 to 1 of 1
  1. #1
    Join Date
    Jun 2003
    Posts
    2

    Unanswered: Transactions called through C API problem

    I am absolutely stymied on a nasty transaction problem. I am using MySQL 3.23.54a-4. From the mysql client, I can issue:

    begin;
    update statements
    rollback;

    and all works as expected.

    However, my Kylix application uses a modified TDataSetProvider component that disables the automatic transaction upon update (this is so that I can update many different tables within one transaction). When I monitor the C API calls that it is making, everything seems fine. I have attached them to this posting in the file SQLMessages.txt. I have tried with and without ";" on the end. I have tried lower case and upper case. I have tried using set autocommit and just using begin. I have tried begin work.

    This problem has had me stopped dead in my tracks for a week and a half. Any help would be greatly appreciated. Thanks.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •