Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2003
    Posts
    127

    Unanswered: Java DB2 Connection Error

    I'm running a multi threaded java application and use app driver (jdbc).
    Each thread makes a connection. Once I hit the fourth connection or so, the application throws this error:
    -----------------------------------------
    PROCESS:Error: DBAgent.init(), Can not initialize DBAgent.COM.ibm.db2.jdbc.DB2Exception: [IBM][CLI
    Driver] SQL1224N A database agent could not be started to service a request, or was terminated as a result of a databas
    e system shutdown or a force command. SQLSTATE=55032
    -----------------------------------------
    The database log does not capture any error.
    Checked the DB2 logs, ran event monitor but didn't help much. The maxagents, maxapplication values are quite high.

    Thanks,
    Kota

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: Java DB2 Connection Error

    Can you tell the platform and DB2 Version ?

    Increase your diaglevel to 4 and check for your messages

    Sathyaram

    Originally posted by Kota
    I'm running a multi threaded java application and use app driver (jdbc).
    Each thread makes a connection. Once I hit the fourth connection or so, the application throws this error:
    -----------------------------------------
    PROCESS:Error: DBAgent.init(), Can not initialize DBAgent.COM.ibm.db2.jdbc.DB2Exception: [IBM][CLI
    Driver] SQL1224N A database agent could not be started to service a request, or was terminated as a result of a databas
    e system shutdown or a force command. SQLSTATE=55032
    -----------------------------------------
    The database log does not capture any error.
    Checked the DB2 logs, ran event monitor but didn't help much. The maxagents, maxapplication values are quite high.

    Thanks,
    Kota

  3. #3
    Join Date
    Jun 2003
    Posts
    127
    Thanks for the response Satyaram. This is an AIX 4.3.3 and DB2 is at 7.2 fixpack 6.
    Even after increasing the diaglevel to 4, it didn't help.

    -Kota

  4. #4
    Join Date
    Jun 2003
    Posts
    127
    I finally found the solution. Check out

    http://www-3.ibm.com/cgi-bin/db2www/...rt?&fn=1009742

  5. #5
    Join Date
    Aug 2003
    Location
    Ohio
    Posts
    38
    Hi! We just upgraded to ver 7, FixPack 10a on AIX 5.1. The document Kota referenced solved our problem. I just wanted to say thank you for saving me hours finding this problem!

    Thanks!
    Jodie

  6. #6
    Join Date
    Jun 2003
    Location
    Toronto, Canada
    Posts
    5,516
    Provided Answers: 1
    Originally posted by Kota
    I finally found the solution. Check out

    http://www-3.ibm.com/cgi-bin/db2www/...rt?&fn=1009742
    One more reason not to run database server and application server on the same machine...
    ---
    "It does not work" is not a valid problem statement.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •