Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2003
    Posts
    1

    Arrow Unanswered: about sybase installation

    hi, everyone

    i am new to sybase. and during my first installation , i met the following troubles:

    my environments: solaris 8, sybase 12.0.

    firstly, i change the file /etc/system:

    set shmsys:shminfo_shmmax=104857600
    set shmsys:shminfo_shmseg=12
    set semsys:seminfo_semmns=200
    set semsys:seminfo_semmni=70


    then i went on installation, and during the whole process, there is no alert or problem happens.

    then i change the .profile, and add the path needed and other enviropnments variables.

    then modify the .dtprofile,
    DTSOURCEPROFILE=ture

    then i begin to start the sybase database.

    user/sybase/ASE-12_0/install/RUN_xxx

    then i get the following warnings:

    Ħ°00:00000:00000:2003/06/19 15:51:00.36 kernel Warning: There is no valid license for ASE server product. Server is booting with all the option features disabled.
    00:00000:00000:2003/06/19 15:51:00.36 kernel basis_dlock: file '/users/sybase/data/master.dat' already in use by a SQL Server
    00:00000:00000:2003/06/19 15:51:00.36 kernel kdconfig: unable to read primary master device
    00:00000:00000:2003/06/19 15:51:00.36 kernel kiconfig: read of config block failed Ħħ




    can any freinds tell me why? or can give me some indication?

    thanks for your helping!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  2. #2
    Join Date
    Jun 2003
    Posts
    30
    It seems the Sybase ASE 12.0 is already in running condition,

    If you try to start it again using RUN_xxx file you wil get the message specified in the errorlog.

    To avoid this, you can stop the Sybase Server and then start it using RUN_xxx file.

  3. #3
    Join Date
    Dec 2002
    Posts
    104
    during the installation it would have asked u for the creation of dataserver and if u have opted it and gave all required details..then it creates dataserver and starts it.

    so when u try to start the dataserver using RUN_XXXX , it gave u am error as it is already started...so just create ur database or shutdown the dataserver first then start it using RUN_XXXX then finally create the database

    hope this meets ur query,

  4. #4
    Join Date
    Jul 2003
    Posts
    2
    First make sure the ASE is not already running.

    If you are very sure, go to look at the $SYBAES directory to see if there is a file called <servername>.krg there. Under rare situation, a ungracefully killed ASE may leave this file behind hindering a restart.

    Simply remove the file and restart.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •