Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2001
    Finland, Kirkkonummi

    Unanswered: SQLServer replication fails with vague error 'text column data incomplete'


    We have a problem with out product enviroment replication.
    Both servers are SQLServer 2000s.
    Replication is transactional replication.
    Source and target schemas should be identical (initial snapshot recreates tables).
    There are NTEXT-columns in tables.

    This has worked like an angel so far but now it started to break apart.
    After updating ntext column (3 rows out of more than 15 000) with updatetext we got error complaining about offset.
    I reinitialized replication and got error
    Text column data incomplete. ODBC error S1000.

    Eventually we tried even recreating those three rows (to get a new pointers to lob data) and deleting old ones but that did not help either.

    And finally our distribution agent hangs up and starts to consume memory. So far it has consumed 2 gigs. Time to kill it again..

    So something is clearly damaged but logs are not giving me any clues (no error messages there). Snapshot is created without any problems but it's distribution does not work.

    So far searching the Net for any information has not revealed anything useful, actually I got only one true hit..

    Thank you,

  2. #2
    Join Date
    Jan 2003
    Nottinghamshire, UK
    Just thought I'd mention that in SQL7 U had to use the WITH LOG Option when using UPDATETEXT to update Published tables.

    checkout Replication -Data Needs and Characteristics - in SQL Server Books Online for 2k

    Last edited by GWilliy; 06-25-03 at 10:24.
    "Everything should be made as simple as possible, but not simpler." - Albert Einstein
    "Everything should be made as complex as possible, so I look Cleverer." - Application Developer

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts