Results 1 to 2 of 2
  1. #1
    Join Date
    Jun 2003
    Posts
    1

    Unanswered: Oracle Intermedia / OrdImage import troubles

    Hello.

    I'm having trouble importing images. I have the following procedure :

    declare
    Image ORDSYS.ORDImage;
    ctx RAW(4000) := null;

    begin
    insert into bilde_test values (
    4, null, ORDSYS.ORDImage.init(), ORDSYS.ORDImageSignature.init());

    SELECT PHOTO into Image FROM bilde_test WHERE photo_id = 4 for update;

    Image.SetSource('file', 'LARSDIR', 'logo_phpBB.gif');
    Image.importFrom(ctx, 'file', 'LARSDIR', 'logo_phpBB.gif');

    UPDATE bilde_test SET photov = Image where photo_id = 4;
    commit;
    End;

    When I try to execute the procedure, I get the following error report. (It's in Norwegian, so I've tried to translate the norwegian text) :

    declare
    *
    ERROR on linj 1:
    ORA-06510: PL/SQL: untreated useddefined exception
    ORA-06512: at "ORDSYS.ORDSOURCE", line 266
    ORA-22288: file- or LOB-operation FILEOPEN failed
    The data is invalid.
    ORA-06512: at "ORDSYS.ORDIMG_PKG", line 701
    ORA-06512: at "ORDSYS.ORDIMAGE", line 223
    ORA-06512: at line 12

    ---
    I've tried several other procedures, with the same result. I've granted read access to the directory. Seems like the trouble occurs around the "import" statement.

    I'm new to Oracle, so I'd very much appreciate all your help

  2. #2
    Join Date
    Dec 2003
    Location
    Oklahoma, USA
    Posts
    354
    I think you are correct about the "import" being the problem. The importfrom seems to (my impression) combine the setsource and import into one step.

    In our application we do this:

    image.setSource( 'file', 'DIR_NAME', 'image.gif' );
    image.import( ctx );

    Has worked every time...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •