Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2003
    Posts
    2

    Unanswered: Clipper 5.1 (Dos) append from command under Windows problem

    Hi,

    I have a real problem running my Dos Clipper application
    under Windows 98, 2000, XP Enviropment. I fill TBrowse object from database with
    append from DatabaseName where ... statment
    but I always get an empty TBrowse object.
    When I check my Database in DBU everything is OK.

    If I change append from ... with "do while not eof - enddo"
    evertying works.



    Does anybody have solution for this (I guess memory problem). I do not have time to change all my code becouse one statment.

    Thank you

  2. #2
    Join Date
    Sep 2003
    Location
    Sacramento, CA
    Posts
    28

    Re: Clipper 5.1 (Dos) append from command under Windows problem

    Hi,
    I think the problem may possibly be in your Clipper version or your Blinker version. If you are using any Clipper before version 5.2E then you are running a big risk of running into some major bugs. The 5.2E is one of the most stable Clipper versions out there. Also I would suggest making sure you are running Blinker version 7 as your linker. I have done what you are doing on XP and 2000 plenty of times using 5.2E.

    I know you probably dont have time to do upgrades but it may be well worth it and should not cost too much since Clipper is not really super high in price. You can probably find copies of Clipper 5.2E on ebay or somewhere like that.

    David

    Originally posted by Mihael
    Hi,

    I have a real problem running my Dos Clipper application
    under Windows 98, 2000, XP Enviropment. I fill TBrowse object from database with
    append from DatabaseName where ... statment
    but I always get an empty TBrowse object.
    When I check my Database in DBU everything is OK.

    If I change append from ... with "do while not eof - enddo"
    evertying works.



    Does anybody have solution for this (I guess memory problem). I do not have time to change all my code becouse one statment.

    Thank you

  3. #3
    Join Date
    Sep 2003
    Location
    Sacramento, CA
    Posts
    28

    Also

    One other thing for the future if the applications you are writing in Clipper are of any kind of importance and has a user base of 5 of more, then you should seriously consider getting Advantage Database Server. With this you can do an AX_APPENDFROM and the append will be done on the server not on the client, so the speed will be amazing. ADS also will cut out 99% of data corruption. I am sure you have run into the corrupt index thing and having to constantly re-index. ADS will also allow you to access your data via windows apps like Visual Basic 6 using either OLEDB provider or ODBC.

    David

  4. #4
    Join Date
    May 2003
    Posts
    65

  5. #5
    Join Date
    Jun 2006
    Posts
    1
    The answer is that you must close the database file you wish to APPEND FROM, as this command tries to open it as Shared ReadOnly, and if its already open exclusively or locked the command will fail and NetErr() will return .T.

    -Thought I'd add this, in case there are other users like myself searching old clipper archives for solutions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •