Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2003
    Posts
    4

    Unanswered: How to connect on shared memory?

    I finally installed service pack 3, and I am told that I Can still access SQL server locally thru shared memory interfaces, if I turn off the Named Pipes and TCP/IP network libraries, thereby stopping UDP port 1434 from listening. This does, indeed stop port 1434 from listening but I can't use Enterprise manager to connect to the server anymore. How to I get it to connect on shared memory?

  2. #2
    Join Date
    Jan 2003
    Location
    Massachusetts
    Posts
    5,800
    Provided Answers: 11
    Shared memory only works from the SQL Server itself. Not terribly useful for a networked application, but there it is. If you are trying to connect from a client machine, you will nee to turn on either TCP/IP or Named Pipes. Then make sure that the client machine is using the same protocol.

    If you are attempting to access the SQL Server locally, you can use the Client Network Utility (in start menu) to reset your default protocol to Shared Memory (or TCP/IP, Named Pipes, etc.)

    Hope this helps.

  3. #3
    Join Date
    Jul 2003
    Posts
    4
    Indeed it did. I found this out myself last night. Of course, remote clients can't connect. But, the purpose of this server is not for remote clients. I'm using it for IIS to connect to, so I can write ASP.Net scripts. There's a checkbox in the Client Network Utility titled "Enable Shared Memory Protocol" that allows you to do this, for future reference if anyone else has this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •