Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2003
    Posts
    3

    Unanswered: Sqlcode: -964, Sqlstate: 57011

    Hi,

    I am trying to insert large amount of data to DB2v8.1 using JDBC connection. I am getting DB2 SQL error: SQLCODE: -964, SQLSTATE: 57011. I have looked around everywhere for this error, but it seems like no one has reported this problem. I hope anyone out there can help me to idetnify this problem and solution?

    I did not have problem when i was trying to insert smaller amount of data.

    thanks.

    silwal

  2. #2
    Join Date
    May 2003
    Location
    USA
    Posts
    5,737
    Did you check the Messages and Codes manual? This manual has 2 volumes and is available from the IBM web site in PDF format. Check the Useful DB2 Stuff at the beginning of this forum.

  3. #3
    Join Date
    Dec 2002
    Posts
    134

    Re: Sqlcode: -964, Sqlstate: 57011

    Hi,

    db2 ? sql0964
    SQL0964C The transaction log for the database is full.
    User Response: Execute a COMMIT or ROLLBACK on receipt of this
    message (SQLCODE) or retry the operation.

    Basically increase log size or commit more frequently

    regards,
    dmitri

  4. #4
    Join Date
    Mar 2003
    Posts
    343
    Or add more primary or secondary logs. If you are circular logging, another thing to do might be to enable logretain.

  5. #5
    Join Date
    Jul 2003
    Posts
    3

    Sqlcode: -964, Sqlstate: 57011

    Thanks for the suggestions, increasing the log file size did not help me.

    How do I create Primary or secondary log files?

    Thanks again

    silwal

  6. #6
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: Sqlcode: -964, Sqlstate: 57011

    There are two db cfg parms, LOGPRIMARY and LOGSECOND..

    If I remember right, setting LOGSECOND=-1, you will not have the log full condition ...

    Better way is to do frequent commits ...


    Cheers

    Sathyaram

    Originally posted by silwal
    Thanks for the suggestions, increasing the log file size did not help me.

    How do I create Primary or secondary log files?

    Thanks again

    silwal
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  7. #7
    Join Date
    Dec 2002
    Posts
    134

    Re: Sqlcode: -964, Sqlstate: 57011

    Originally posted by sathyaram_s
    There are two db cfg parms, LOGPRIMARY and LOGSECOND..
    If I remember right, setting LOGSECOND=-1, you will not have the log full condition ...
    I do not think it will work, at least in v7
    update db cfg for test using LOGSECOND -1
    SQL0104N An unexpected token "-1" was found following "LOGSECOND". Expected
    tokens may include: "<unsigned-short-number>". SQLSTATE=42601


    In v7, if you want to increase log file size, there are 3 parameters to play with: logprimary, logsecond and logfilsiz.

    The total log file size limit is 32 GB. That is, the number of log files (logprimary + logsecond) multiplied by the size of each log file in bytes (logfilsiz * 4096) must be less than 32 GB.

    I do recommend you switch to more frequent commits or use load

  8. #8
    Join Date
    Jul 2003
    Posts
    3

    Sqlcode: -964, Sqlstate: 57011

    I am using DB2 v8.1 PE.


    Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •