Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2003
    Posts
    2

    Unanswered: Problem restoring backup

    I am running SQL 7...

    I had a database on a Sql Server on a WinXP machine but I needed to reinstall that machine and I installed Win2k...

    Before I format the machine I have made a backup from my database. Now, on the Win2k, I cant restore this backup. Sql Server shows the following error message:

    The volume on device 'c:\backup.bak' is not a member of the media family.

    Plz, help me on this... I dont know much about Sqlserver and this is the ONLY backup I have... The backup file seems fine... There was no errors during the backup proccess...

    If u dont know whats happening, could u tell if exists some program that can read the backup file and extracts its data to another format?

  2. #2
    Join Date
    Aug 2002
    Location
    Charlotte NC
    Posts
    665

    Re: Problem restoring backup

    What I do is...
    i create a backup device that is the same name as the old backup.
    i then put the backup file where u set up the backup device to be. at this point the server should see it and use it as a lagit device
    Jim


    Originally posted by trojahn
    I am running SQL 7...

    I had a database on a Sql Server on a WinXP machine but I needed to reinstall that machine and I installed Win2k...

    Before I format the machine I have made a backup from my database. Now, on the Win2k, I cant restore this backup. Sql Server shows the following error message:

    The volume on device 'c:\backup.bak' is not a member of the media family.

    Plz, help me on this... I dont know much about Sqlserver and this is the ONLY backup I have... The backup file seems fine... There was no errors during the backup proccess...

    If u dont know whats happening, could u tell if exists some program that can read the backup file and extracts its data to another format?

  3. #3
    Join Date
    Jul 2003
    Posts
    2
    JDionne,

    I need to ask u for a little more favor... Could u give me more details on how to do that? I really dont know much about Sql Server... I just follow the setup procedure of my so called technical support that now says that I did something wrong...

    Edit -=-=-=-=-=-
    I just figure out how to do what u said but theres a major problem... I dont know where the backup device was on the first machine... I there a way to figure that out?
    Last edited by trojahn; 07-23-03 at 19:19.

  4. #4
    Join Date
    Aug 2002
    Location
    Charlotte NC
    Posts
    665
    The location of the first back up dosent mater. I would create the backup device in eh mssql\backups directory just to stick to a standard.
    Once u have created that device with the same name as the old backup file and move it to that dir, the server will use the file.

    the following code will tell u whats in the backup when u go to restore.
    run this in query analizer substituting your backup device name
    Code:
    RESTORE FILELISTONLY
       FROM [Maersk Data Warehouse Full Backup]
    after u know whats in the device u can use the following code to restore it. u will need to change the database name, backup device and mdf,ldf, (and if u have a ndf) file names
    the To line indicates wehre u want it to restore to and again i would follow the standard just so u know where they are. If u have any questions just post it and ill see if i can help
    Regards Jim
    Code:
    RESTORE DATABASE [Maersk Data Warehouse] 
       FROM [Maersk Data Warehouse Full Backup]
    	with recovery
    	, move 'Maersk Data Warehouse_Data'to 'E:\MSSQL\Data\Maersk Data Warehouse_Data.MDF'
    	, move 'Maersk Data Warehouse_Log' to 'F:\MSSQL\Data\Maersk Data Warehouse_Log.LDF'
    	, move 'Maersk Data Warehouse User Tables'to 'E:\MSSQL\Data\Maersk Data Warehouse_Data.NDF'

    Originally posted by trojahn
    JDionne,

    I need to ask u for a little more favor... Could u give me more details on how to do that? I really dont know much about Sql Server... I just follow the setup procedure of my so called technical support that now says that I did something wrong...

    Edit -=-=-=-=-=-
    I just figure out how to do what u said but theres a major problem... I dont know where the backup device was on the first machine... I there a way to figure that out?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •