Results 1 to 3 of 3
  1. #1
    Join Date
    Jul 2003
    Posts
    37

    Unanswered: What is this ERROR?

    Here is some background on the situation at hand: I'm working on a project with these two servers: MIDT and MIDQ. Those servers were linked together about 2 weeks ago. I am logging into both servers as the system administrator. user name has same permissions on both servers.

    Here is a definition of the problem. I need to be able to perform a select statement across servers. Up until two days ago, I was able to perform such a query… yesturday I came in and I could perform a query from MIDQ to MIDT, but not the opposite way around. So for instance, when logged into MIDT, I performed the query select * from midq.master.dbo.syscolumns and the error message below came up…

    Server: Msg 7399, Level 16, State 1, Line 1
    OLE DB provider 'SQLOLEDB' reported an error. The provider did not give any information about the error.
    OLE DB error trace [OLE/DB Provider 'SQLOLEDB' IUnknown::QueryInterface returned 0x80004005: The provider did not give any information about the error.].

    Well THANK YOU error message for being so EXPLANATIONAL!!!!! At first I thought something was wrong with the linked server connection… it has been dropped and recreated many times since this situation arose to no avail.

    Service packs were updated over 2 months ago so its not that either... what is wrong with this situation? Like I said I dropped and recreated the linked server and remote server connections for both servers. Why am I all of a sudden only able to perform a query when logged onto MIDQ to MIDT? Does anyone have any solutions as to how to correct or approach this situation????

  2. #2
    Join Date
    Jul 2003
    Posts
    37
    I wanted to see if this was a permissions thing... it is not. I set up two identical new users on both sides giving full access to database master along with system administrator status. Attempted to perform a query for MIDT to MIDQ on master yielded the above error message once again.
    I also just created another linked server connection from scratch between MIDT and a server name MIDT2. A query from MIDT to MIDT2 yielded the same error message.

  3. #3
    Join Date
    Feb 2003
    Location
    Milano, Italy
    Posts
    80
    i belive that the sp3 give more explanation. install it if you can.
    Davide Mauri
    http://www.davidemauri.it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •