Results 1 to 8 of 8
  1. #1
    Join Date
    Jul 2003
    Posts
    6

    Question Unanswered: Compiling db2uext2 for tsm on db2 v 8.1.2

    I am running db2 V 8.1.2 on AIX 5.1 . I am using TSM 5.1.5. All are 64bit .

    I try to compile the db2uext2 for tsm (source is db2uext2.ctsm) and receive errors. I did not have this problem with db2 v7 (32-bit).

    Has anyone done this before ?

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: Compiling db2uext2 for tsm on db2 v 8.1.2

    Any specific error message ?

    cheers
    Sathyaram

    QUOTE]Originally posted by sherriehill
    I am running db2 V 8.1.2 on AIX 5.1 . I am using TSM 5.1.5. All are 64bit .

    I try to compile the db2uext2 for tsm (source is db2uext2.ctsm) and receive errors. I did not have this problem with db2 v7 (32-bit).

    Has anyone done this before ?
    [/QUOTE]
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Jul 2003
    Posts
    6
    Well that would help wouldn't it !!!

    The error messages are :

    <papprddb>/home/db2inst1 $cc -o db2uext2 db2uext2.c
    /usr/tivoli/tsm/client/api/bin64/libApiTSM64.a
    -I/usr/tivoli/tsm/client/api/b>
    ld: 0711-317 ERROR: Undefined symbol: .dsmQueryApiVersion
    ld: 0711-317 ERROR: Undefined symbol: .dsmSetUp
    ld: 0711-317 ERROR: Undefined symbol: .dsmInit
    ld: 0711-317 ERROR: Undefined symbol: .dsmCleanUp
    ld: 0711-317 ERROR: Undefined symbol: .dsmBeginQuery
    ld: 0711-317 ERROR: Undefined symbol: .dsmGetNextQObj
    ld: 0711-317 ERROR: Undefined symbol: .dsmEndQuery
    ld: 0711-317 ERROR: Undefined symbol: .dsmBeginGetData
    ld: 0711-317 ERROR: Undefined symbol: .dsmGetObj
    ld: 0711-317 ERROR: Undefined symbol: .dsmGetData
    ld: 0711-317 ERROR: Undefined symbol: .dsmEndGetObj
    ld: 0711-317 ERROR: Undefined symbol: .dsmEndGetData
    ld: 0711-317 ERROR: Undefined symbol: .dsmTerminate
    ld: 0711-317 ERROR: Undefined symbol: .dsmRegisterFS
    ld: 0711-317 ERROR: Undefined symbol: .dsmBindMC
    ld: 0711-317 ERROR: Undefined symbol: .dsmBeginTxn
    ld: 0711-317 ERROR: Undefined symbol: .dsmSendObj
    ld: 0711-317 ERROR: Undefined symbol: .dsmSendData
    ld: 0711-317 ERROR: Undefined symbol: .dsmEndSendObj
    ld: 0711-317 ERROR: Undefined symbol: .dsmEndTxn
    ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain more
    information.

  4. #4
    Join Date
    Apr 2003
    Location
    Phoenix, AZ
    Posts
    177
    I don't have TSM 5.1 installed, but the parameters you used on your "C" compiler invoke look like you're missing the header file from xopen.

    This is my (32-bit) compile, not where -I points:

    cc_r -o db2usext2 db2usext2.c /t4.2/tivoli/tsm/client/api/bin/libApiDS.a -I /t4.2/tivoli/tsm/client/api/bin/xopen
    Fred Prose

  5. #5
    Join Date
    Jul 2003
    Posts
    6
    I don't have an xopen directory in the tsm path, which with my release
    is /usr/tivoli/tms/client/api/bin64

    Thanks,
    Sherrie

  6. #6
    Join Date
    Apr 2003
    Location
    Phoenix, AZ
    Posts
    177
    check if you have an xopen directory under bin (not bin64). The binaries are under bin64, but the libraries all seem to be under bin/xopen.
    Fred Prose

  7. #7
    Join Date
    Jul 2003
    Posts
    6
    Fred,

    I ended up opening a case with IBM. I needed to use the -q64 option on the compile. I did and was able to compile with no errors.

    Thankyou for you time.
    Sherrie

  8. #8
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650
    Thanks Sherrie for giving a feedback ...

    Much appreciated

    Sathyaram
    Visit the new-look IDUG Website , register to gain access to the excellent content.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •