Results 1 to 4 of 4
  1. #1
    Join Date
    Jul 2003

    Question Unanswered: Help: Odd Error Mess :The table 'terms' has been created but its max rowsize(8850)

    Hi, I've come across a error message and I'm not sure what to do.

    Warning: The table 'terms' has been created but its maximum row size (8850) exceeds the maximum number of bytes per row (8060). INSERT or UPDATE of a row in this table will fail if the resulting row length exceeds 8060 bytes.

    I've tried playing with odd and ends, but I'm still getting the message does anyone know hwo you expand the maxium number of bytes per row.

    Thanks For any help.

  2. #2
    Join Date
    May 2003
    Epsom, United Kingdom

    Re: Help: Odd Error Mess :The table 'terms' has been created but its max rowsize(8850)

    You obviously have too much information to fit in one row.

    This error message is caused by either a table with too many columns or a few very wide columns.

    The best solution is to break up your table in to 2, 3 smaller tables and have a one-to-one relationship. The combination of the matching rows will meet your larger rowsize requirement.
    Shadow to Light

  3. #3
    Join Date
    Jul 2003
    SQL Server has a 8K block size, which means that a single row cannot exceed this size (8060 bytes). When all column sizes are added up, SQL is telling you that that number potentially exceeds that size (this is because of varchars). You only have 2 options, 1 - reduce the size of your columns until the total is below 8060, or 2 - split the table up - as the previous post suggests.

  4. #4
    Join Date
    Feb 2003
    Milano, Italy
    You cannot "force" sql to overcome the limit of 8060 bytes per row.

    Anyway you'll get an error ONLY IF your actual data is larger that 8060 bytes.
    For example if your table is made of two columns of VARCHAR(5000) you'll get the warning you already know.
    Than you can insert values in your table with no problem, expect for that rows that are bigger that the near 8Kb limit.

    If you really need to have not virtual limits you can use the TEXT or IMAGE data types.
    Davide Mauri

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts