Results 1 to 8 of 8
  1. #1
    Join Date
    May 2003
    Posts
    369

    Unanswered: db2 migration error

    Hi everyone,

    We are migrating our test DB2 UDB 7.2 DB (32 bit) on AIX 5.2L (32 bit) to DB2 UDB 8.2 (32 bit). I ran the db2ckmig on all databases and everything came back okay except for our sandbox system we get

    $ db2ckmig -esample -l upgrade -u db2inst1 -p db2
    Could not load program /usr/lpp/db2_07_01/bin/db2ckmig_exe:
    Dependent module libdb2.a(shr.o) could not be loaded.
    Could not load module libdb2.a(shr.o).
    Error was: No such file or directory

    Any tips on what I need to do to fix this error? Thanks in advance

    Scott

  2. #2
    Join Date
    Dec 2002
    Posts
    134

    Re: db2 migration error

    I think I had similar problem. The problem was links created for db2 v7 libs (they are used if you do not specify lib path for code/stored procs compilation).

    Try removing them
    /usr/lpp/db2_07_01/cfg/db2rmln

  3. #3
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: db2 migration error

    Its generally a good practice to use this db2rmln whenever you have more than one version of db2 running on a box ...



    Originally posted by chuzhoi
    I think I had similar problem. The problem was links created for db2 v7 libs (they are used if you do not specify lib path for code/stored procs compilation).

    Try removing them
    /usr/lpp/db2_07_01/cfg/db2rmln
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  4. #4
    Join Date
    May 2003
    Posts
    369

    wrong version of db2ckmig used

    Spoke with IBM DB2 Support. I was using the DB2 UDB v7.2 version of db2ckmig which is most likely what caused the problem. Once I install DB2 8.1 and the fixpacks and test the migration I will know for certain and use the DB2 v8.1.2 db2ckmig tool.

  5. #5
    Join Date
    Aug 2003
    Location
    London
    Posts
    25

    Re: db2 migration error

    Originally posted by mixxalot



    Can you please let me how you have solved this problem.. I did the migration on the AIX box having Ver 5. DB2 previous version was 7.2 and now I have migrated with DB2 ver 8 fix pack 2.

    There are two instances once works perfectly fine and other has thown the prob what you mentioned in your mail earlier.

    Can you let me know whats the way to get around.

    Thanks/Regards,
    Suresh



    Hi everyone,

    We are migrating our test DB2 UDB 7.2 DB (32 bit) on AIX 5.2L (32 bit) to DB2 UDB 8.2 (32 bit). I ran the db2ckmig on all databases and everything came back okay except for our sandbox system we get

    $ db2ckmig -esample -l upgrade -u db2inst1 -p db2
    Could not load program /usr/lpp/db2_07_01/bin/db2ckmig_exe:
    Dependent module libdb2.a(shr.o) could not be loaded.
    Could not load module libdb2.a(shr.o).
    Error was: No such file or directory

    Any tips on what I need to do to fix this error? Thanks in advance

    Scott

  6. #6
    Join Date
    May 2003
    Posts
    369

    use v8 db2ckmig tool for upgrade

    I had to run the db2ckmig tool for v8.1 to perform the database instance migration and upgrade from DB2 UDB 7.2 on AIX 4.3.3 to DB2 UDB 8.1.2 on AIX 5.2L both instance and O/S are 32 bit. I received the errors because I was using the db2ckmig v7.2 tool instead of the later v8.1 tool. You have to use the newer release of db2ckmig when upgrading DB2 to v8.1.2.

  7. #7
    Join Date
    Apr 2003
    Location
    Boston, MA
    Posts
    4
    I have a problem with db2ckmig - after i installed the v8.1 on the nt box, i did a db2ckmig, it failed on "can't connect to sample". I was running the v8 version of db2ckmig. But the install procedure never say one should do the db2ckmig before the install.

    When i did a "db2 connect to sample", it failed and said that i have to migrate the database to v8 before i can use it.

    So I decide to do the migration, but i can't find DB2IMIGR in the SQLLIB\Bin directory!!!

    I'm stuck...

  8. #8
    Join Date
    Apr 2003
    Location
    Boston, MA
    Posts
    4
    Never mind!

    Here is the answer: Window version of db2 udb v8 upgrade doesn't require to migrate the instance like what in a unix machine does, hence there's no need to have a DB2IMIGR module in \sqllib\bin. Simply migrate your databases after the installation of v8, you will be set.

    Thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •