Results 1 to 9 of 9
  1. #1
    Join Date
    Aug 2003
    Posts
    5

    Unanswered: How to setup Oracle 9 server/client relation in Win2k?

    Back in school lab, I uses SQL Plus to access a DB.

    Got a Oracle 9 client CD from a school mate and I am using Win2k at home, would like to learn more about SQL thus been trying to setup Win2k and Oracle 9 client at home but to no avail.

    Is it possible to use Oracle 9 client on Win2k and able to create DB and use SQL Plus to access the DB?

  2. #2
    Join Date
    Nov 2002
    Posts
    833
    want do you want to do? cllient only or both client and server on your WS

    setting up Oracle 9i _Client SW on your WIN2K WS requires running the setup from the client install CD
    Follow the instructions and chose between custom install or a app dev client installation

    you need to configure the tnsnames.ora for the oracle Server you want to work with (see $ORACLE_HOME/Network\admin).

    you will need a connection to the server where Oracle 9i SID is running,

    or you can configure isqlplus and use the web interface to connect to your testserver's SID

  3. #3
    Join Date
    Jul 2003
    Posts
    2,296
    If you are connecting to the DB from the server-side (ie: the DB is on your machine) then you do not need to supply a SID/HOST in your connection parameters.

    sqlplus scott/tiger

    that would connect you to your DB.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  4. #4
    Join Date
    Aug 2003
    Posts
    5
    So say, I wish to connect to DB on my comp, create DB on my comp, what do I need to do?

    Any links to this or any instructions for this?

    Sorry but very new to setting up SQL and even to SQL itself.

    I followed as said by The_Duck,
    using scott/tiger for SQL Plus,

    it says ORA-12560: TNSrotocol adapter error.

    So what's wrong with my setup?

    Had used MSSQL before, so like MSSQ, do I need to use enterprise manager to create a DB first? If so, do I launch standalone or login to Oracle Management Server?

    Thanks a lot.

  5. #5
    Join Date
    Apr 2002
    Location
    California, USA
    Posts
    482
    The "ORA-12560 TNS protocol adapter error" means you didnt' setup ORACLE_SID variable on your server. Try this:

    c:\> set oracle_sid=<YOUR_DB_SID_VALUE_HERE>
    c:\> sqlplus /nolog
    SQL> connect scott/tiger


    Hope that helps,

    clio_usa
    OCP - DBA
    Visit our Web Site

  6. #6
    Join Date
    Aug 2003
    Posts
    5
    I went to run--> cmd

    set oracle_sid=adsid <--up to what I want I suppose or?)
    -->sqlplus /nolog
    --->connect
    user:scott
    pass:tiger

    shows me
    ORA-12560 TNS protocol adapter error.

    Or is there something I must configure in the net configuration assistant?

    Thanks once again.

  7. #7
    Join Date
    Aug 2003
    Location
    Lelystad - Netherlands
    Posts
    7
    Do you have a database running on that you can (or should be able to) connect to?
    If not set up a database first.

    Then you need to connect to the database and therefore needs to be some information in the tns-names file (tnsnames.ora). And if then everything is ok. it should work

  8. #8
    Join Date
    Aug 2003
    Posts
    5
    Do not think so, so far, I haven't even been able to find any listener starting.

    Under my control panel, admins, services, I could not find, LSNRCTL in those.

    Could that be the main problem as most of the error keeps telling me about listener.

    I use search for file/folder name LSNRCTL but in all my drive, there is no such item.

    Also search for svrmgrl but also no such item.

  9. #9
    Join Date
    Aug 2003
    Location
    Lelystad - Netherlands
    Posts
    7
    I think you first need to set up a database on your machine. And if you do that then you will get the rest automaticly.
    But that is not possible with an Oracle-client cd.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •