Results 1 to 9 of 9
  1. #1
    Join Date
    Aug 2003
    Posts
    7

    Unanswered: Need HELp with Oracle 8i Listener...

    I need to lock down Oracle 81 to use port 1521 for all traffic. I have been able to make it happen using the registry value USE_SHARED_SOCKETS = TRUE for version 8.0, BUT I cannot get it to work with Oracle 8i running ton Windows 2000 Server.

    Any help greatly appreciated!!!!


    -DJ

  2. #2
    Join Date
    Mar 2002
    Location
    Reading, UK
    Posts
    1,137
    I've managed to get it to work with Oracle 9i on Win2K so it should still work. Are you using MTS?

    Alan

  3. #3
    Join Date
    Jul 2003
    Posts
    2,296
    yeah, you have to use MTS.

    Set the parameter in the init.ora file.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  4. #4
    Join Date
    Aug 2003
    Posts
    7
    MTS?? I'm not sure what you are referring to...?


    -DJ

  5. #5
    Join Date
    Jul 2003
    Posts
    2,296
    look up information regarding multi-threaded server

    also, for the parameter:
    mts_dispatchers

    http://download-west.oracle.com/doc...nproc.htm#12007

    Last edited by The_Duck; 08-08-03 at 13:03.
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  6. #6
    Join Date
    Aug 2003
    Posts
    7
    That link is broken. Any other place I can get it??

  7. #7
    Join Date
    Aug 2003
    Posts
    7
    To setup MTS, is it just an init file change or much further?


    -DJ

  8. #8
    Join Date
    Jul 2003
    Posts
    2,296
    Originally posted by djtech2k
    That link is broken. Any other place I can get it??
    sorry, this one works:
    http://download-west.oracle.com/docs...proc.htm#12007

    in that doc, this specific area is going to set up your db the way you want:
    PHP Code:
    Example 4-
    To force the exact location of dispatchers
    add the PORT as follows

    MTS_DISPATCHERS="(ADDRESS=(PROTOCOL=TCP)(HOST=144.25.16.201)(PORT=5000))"     
    MTS_DISPATCHERS="(ADDRESS=(PROTOCOL=TCP)(HOST=144.25.16.201)(PORT=5001))" 
    - The_Duck
    you can lead someone to something but they will never learn anything ...

  9. #9
    Join Date
    Aug 2003
    Posts
    7
    nevermind guys. I actually got it to work.

    I had to add the USE_SHARED_SOCKET=TRUE into the registry. I actualled added it in 3 places to be safe it was in the correct place AND I had to put it in Windows 2000 System Variables. After a reboot, it seems to work fine. I am going to check the ports in the listener.log, but because of network config, it would not be working if it was still trying to come back on the random port.

    Thanks again for the help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •