Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2003
    Location
    Austin, Texas
    Posts
    12

    Unanswered: DAS failed after update FP2 (DB2/64 8.1, AIX/5.2)

    Hi..
    I have a problem with the DAS on DB2/64 8.1 (FP2), AIX/5.2
    After I applied the service pack the DAS quit working. At least that's when
    I noticed it.
    I dropped the DAS "dasdrop" and tried to recreate but it still does not
    work.
    The only thing that is not standard on the installation is that I have JDK 1.4/64 running.
    --------------------------------
    # dascrt -u db2_das
    [YOU HAVE NEW MAIL]
    exec(): 0509-036 Cannot load program /export/home/db2_das/das/bin/db2admin
    because of the following errors:
    0509-150 Dependent module
    /usr/opt/db2_08_01/lib64/libdb2dasapi.a(shr.o) could not be loaded.
    0509-152 Member shr.o is not found in archive
    DBI1070I Program dascrt completed successfully.
    ------------------------------------------
    I did find a similar problem in Can't start DAS after DB2 7.2 updated to
    64-bit (http://dbforums.com/arch/155/2003/4/651820)

    Any help on this would be appriciated
    JR Andreassen
    janrune_NOSPAM@io.com

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: DAS failed after update FP2 (DB2/64 8.1, AIX/5.2)

    I'm sure you would have tried the slibclean suggested in the other post ?

    Maybe, you can try to run dascrt in debug mode (-d option) .... This may give more information

    cheers
    Sathyaram

    Originally posted by janrune
    Hi..
    I have a problem with the DAS on DB2/64 8.1 (FP2), AIX/5.2
    After I applied the service pack the DAS quit working. At least that's when
    I noticed it.
    I dropped the DAS "dasdrop" and tried to recreate but it still does not
    work.
    The only thing that is not standard on the installation is that I have JDK 1.4/64 running.
    --------------------------------
    # dascrt -u db2_das
    [YOU HAVE NEW MAIL]
    exec(): 0509-036 Cannot load program /export/home/db2_das/das/bin/db2admin
    because of the following errors:
    0509-150 Dependent module
    /usr/opt/db2_08_01/lib64/libdb2dasapi.a(shr.o) could not be loaded.
    0509-152 Member shr.o is not found in archive
    DBI1070I Program dascrt completed successfully.
    ------------------------------------------
    I did find a similar problem in Can't start DAS after DB2 7.2 updated to
    64-bit (http://dbforums.com/arch/155/2003/4/651820)

    Any help on this would be appriciated
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Aug 2003
    Location
    Austin, Texas
    Posts
    12

    Re: DAS failed after update FP2 (DB2/64 8.1, AIX/5.2)

    Originally posted by sathyaram_s
    I'm sure you would have tried the slibclean suggested in the other post ?

    Maybe, you can try to run dascrt in debug mode (-d option) .... This may give more information

    cheers
    Sathyaram
    I did try the procedure to no avail.
    I also tried with the '-d' option the only thing it showed was that the command:
    "/usr/opt/db2_08_01/instance/db2iexec db2_das /export/home/db2_das/das/bin/db2admin start "
    was the failing command.
    Any Ideas ???
    Thanks
    JR
    JR Andreassen
    janrune_NOSPAM@io.com

  4. #4
    Join Date
    Nov 2002
    Location
    Delaware
    Posts
    186

    Re: DAS failed after update FP2 (DB2/64 8.1, AIX/5.2)

    Try starting the das as db2as or what ever id you installed it with, According to IBM, when your using 64 bit executables for you database, das is still only a 32 bit db.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •