Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2003
    Posts
    2

    Question Unanswered: Informix IDS 9.4 connectivity

    I have installed the trial version of IDS 9.4 on a RedHat 9.0 box. The docs were terrible, but I did get it installed and am able to access it locally via DBACCESS as well as the ServerStudioJE tool (both on the same box as IDS). I downloaded the Client SDK from IBM and installed it on my Win2K box. Next I setup a DSN and tried to make an ODBC connection..it failed. I tried to telnet the server at the port I gave the IDS service in etc/services...connection refused. I tried again to telnet, this time locally on the server using localhost...connected no problem.

    Many online postings talk about starting the sqlexecd daemon in $INFORMIXDIR/lib/ however I have gone all through the $INFORMIXDIR and found no sqlexecd. Do I need to install something? At this point I only have the trial version of IDS 9.4 installed.

    Current setup...
    /etc/services
    demo_on_tcp 1533/tcp

    $INFORMIXDIR/etc/sqlhosts
    demo_on onsoctcp switch demo_on_tcp

    What do I need to do to receive connection from other machines?

  2. #2
    Join Date
    Aug 2003
    Posts
    2

    Smile Resolved

    I resolved this issue myself. After posting this question I ran netstat and noticed that the IDS server was listening on the correct port, but on the loopback address (127.0.0.1), so I changed this by putting the servers IP address is the sqlhosts file and restarting the IDS server. I am able to connect through the IBM ODBC drivers that come w/ the Informix Client SDK.

    Thanks anyway.

  3. #3
    Join Date
    Oct 2002
    Posts
    8

    port bind ip address

    u can edit config file /etc/hosts to bind the port with spec ip. And u can bind different ip address using alias.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •