Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2003

    Unanswered: Installing SQL 2000 On active/active cluster

    I am trying to install SQL 2000 Ent on a Win2k3 cluster.
    I have check both local and domain privlages and they are good.
    I have performed MS work around so SQL sp2 and below can be installed on win2k3.
    And I keep getting the following error during install...

    An error occurred while creating virtual server resources for
    clustering.Cluster specific registry entries couldn't be written.

    Does anybody have any ideas?
    Last edited by jherren; 08-15-03 at 16:47.

  2. #2
    Join Date
    Aug 2003

    Check remote registry service

    Check the privilages for the service account and the Account in which you logged in for Installation has folloing privilages .

    Part of Local Admin
    In Local Policy
    1. Act as part of operating system
    2. Log on as service
    Make sure in the services :Remote registry service is up

  3. #3
    Join Date
    Aug 2003

    Re: Check remote registry service

    Privlages are good and remote registry service is running !

  4. #4
    Join Date
    Nov 2003

    was this issue resolved?

    Did you manage to resolve this issue? Did you get any USEFULL help from Microsoft support? Please post a few words of wisdom if so.

    We have exactly the same problem and I've been struggling with it for a few weeks. Any help/advice is welcome.

    I use SQL 2000 EE SP3 install (i.e with SP3 already included in installation) and still get the same error: "cluster-specific registry could not be written". All the simptoms are the same. I can install single-node virtual server, but if I try to install on both-nodes I've got mentioned message. The same happens if I try add second node to successfully installed single-node virtual server.
    Last edited by vpetruk; 11-27-03 at 10:50.

  5. #5
    Join Date
    Aug 2003
    My issue ended up being security on the cluster was to tight.
    Once I loosened my security policies it started working fine.
    Specifically the registry was being locked down by a Windows 2000 DC which does'nt have all the proper setting that Windows 2003 has.
    I eventually upgraded the DC to 2003 to help with this matter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts