Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2002
    Posts
    25

    Exclamation Unanswered: time connect to DB

    I have a DB, that was recovered from backup. The problem is that when I connect myself to this DB, the time of delay takes much.
    I am working with a UDB DB2 version 8.1 with fixpack 2.
    Thanks for everything.

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: time connect to DB

    Is it always or only the first time or when you are the first one to connect to a inactive database ?

    If you are in category 2 or 3, there is nothing to worry

    Cheers
    Sathyaram

    Originally posted by zarconja
    I have a DB, that was recovered from backup. The problem is that when I connect myself to this DB, the time of delay takes much.
    I am working with a UDB DB2 version 8.1 with fixpack 2.
    Thanks for everything.
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Dec 2002
    Posts
    25

    Red face Re: time connect to DB

    when I do login to the DB for the first time, it delays enough in connecting itself and it leaves the message Windows saying that there is no sufficient virtual memory, but after about 5 minutes approximately is gotten to connect. When doing another one login to the same DB this is made but fast. It wanted that the first time that it connects to me makes equal of fast.

  4. #4
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: time connect to DB

    You can't help ...

    The first connection is always slow ... This is becuase the database will be allocating system resources(bufferpool and other database memory) and will be initializing the log files ... If the database was not stopped gracefully, an additional step 'Crash Recovery' has to be done ....

    To avoid all these in the first connection, you can use the ACTIVATE Database Command ... The resources will be in allocated state until you issue DEACTIVATE Database command ...

    Cheers

    Sathyaram

    Originally posted by zarconja
    when I do login to the DB for the first time, it delays enough in connecting itself and it leaves the message Windows saying that there is no sufficient virtual memory, but after about 5 minutes approximately is gotten to connect. When doing another one login to the same DB this is made but fast. It wanted that the first time that it connects to me makes equal of fast.
    Visit the new-look IDUG Website , register to gain access to the excellent content.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •