I have an Oracle DB 8.1.5. on a Server, whit a table I want to access
from another server with Oracle 7.2.2, using forms 3.0.16.

I have a link on the 7.2.2BD, that access the table in de 8.1.5.DB.

But when I want to retrieve rows from this table, using any kind of cursor,
an error appears:
1002-fetch out of sequence.

This error appears only from forms.

If I use plsql in a package, everything is ok.

This version of forms is too old?. Can I solve this error?.

I'll be waiting from your help.