Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2003
    Posts
    3

    Unanswered: Question on character set : Client Vs Server

    Greetings,

    Situation:
    i'm using a db in which i've inserted data from various language (french,german,slave characters,...).
    I set up my db with character set = unicode value. And my OS (win2k) has nls_lang = American_america.UTF8.

    Problem:
    When i query my db, some french,german and other slave characters do not appear properly.A problem of conversion between server and my client.Since i've set up my db as unicode so does my OS, how can i solve that ?

    Appreciate your help.
    Cheers - lb

    SUM UP
    running 9i R2 with these values:
    * server side (from nls_dba_parameters object)
    - character set value = AL32UTF8 (unicode)

    * Client parameters (from the registry file)
    - nls_lang = 'American_america.UTF8'

    * French and other german characters are not appearring properly.

  2. #2
    Join Date
    Aug 2003
    Posts
    3

    Found Out The Solution

    Hi There

    found out the solution. In fact my OS/db are configured like this:
    - the client os has nls_lang = American_american.UTF8
    - the database has nls_characterset = AL32UTF8

    While using sqlldr to insert data, i have processed like this:
    - saved the file as "Text(Tab delimited)
    - changed that file encoding to UTF-8
    - executed the control file.

    Result
    All multilingual data has been loaded successfuly without any misconversion.

    lam



    Originally posted by lamso
    Greetings,

    Situation:
    i'm using a db in which i've inserted data from various language (french,german,slave characters,...).
    I set up my db with character set = unicode value. And my OS (win2k) has nls_lang = American_america.UTF8.

    Problem:
    When i query my db, some french,german and other slave characters do not appear properly.A problem of conversion between server and my client.Since i've set up my db as unicode so does my OS, how can i solve that ?

    Appreciate your help.
    Cheers - lb

    SUM UP
    running 9i R2 with these values:
    * server side (from nls_dba_parameters object)
    - character set value = AL32UTF8 (unicode)

    * Client parameters (from the registry file)
    - nls_lang = 'American_america.UTF8'

    * French and other german characters are not appearring properly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •