Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2003
    Posts
    2

    Question Unanswered: DB2APP.dll in version 6 and 7

    Hi,
    I have written the small Windows app (using Visual C++) and using DB2 client v.7 while the server resides on DB2 version 6. I had no problems with running from my PC, but faced the problems (sqlasetda@24 not found in DB2APP.dll) while trying to run from the server.
    Do I have to run this app only from the client with version 7?

    Zbigniew

  2. #2
    Join Date
    Aug 2001
    Location
    UK
    Posts
    4,650

    Re: DB2APP.dll in version 6 and 7

    You may have to recompile your app using the v6's db2app.dll ..

    Cheers
    Sathyaram

    Originally posted by zbika
    Hi,
    I have written the small Windows app (using Visual C++) and using DB2 client v.7 while the server resides on DB2 version 6. I had no problems with running from my PC, but faced the problems (sqlasetda@24 not found in DB2APP.dll) while trying to run from the server.
    Do I have to run this app only from the client with version 7?

    Zbigniew
    Visit the new-look IDUG Website , register to gain access to the excellent content.

  3. #3
    Join Date
    Feb 2004
    Posts
    1

    Re: DB2APP.dll in version 6 and 7

    Hi,
    I' ve the same problem while triying to link a project which includes a C file generated by our host using bind & prep commands. Our Host has been recently upgraded to version 7. While I' ve reproduced the link error using both client versions 6.1 and 7.1..., also I've changed the DB2APP.dll component wich is supposed to include de undefined symbol.

    Did you solve this problem?

    Regards

    Originally posted by zbika
    Hi,
    I have written the small Windows app (using Visual C++) and using DB2 client v.7 while the server resides on DB2 version 6. I had no problems with running from my PC, but faced the problems (sqlasetda@24 not found in DB2APP.dll) while trying to run from the server.
    Do I have to run this app only from the client with version 7?

    Zbigniew

  4. #4
    Join Date
    Aug 2003
    Posts
    2

    Re: DB2APP.dll in version 6 and 7

    Hi,
    the problem not really solved. Admins changed database to... MVS version, so I had ro rebind. Now it works, as all the customers have correct client version.
    But I can't say I solved the problem as I did not look for the solution.

    Originally posted by XDEVIALA
    Hi,
    I' ve the same problem while triying to link a project which includes a C file generated by our host using bind & prep commands. Our Host has been recently upgraded to version 7. While I' ve reproduced the link error using both client versions 6.1 and 7.1..., also I've changed the DB2APP.dll component wich is supposed to include de undefined symbol.

    Did you solve this problem?

    Regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •