Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2003
    Posts
    2

    Smile Unanswered: New to Oracle :o(

    Hello

    I've just installed oracle 8i (Release 8.1.5.0.0) on XP home edition, I can't seem to log on to the database that I have set up. I get the following error:

    ERROR:
    ORA-12500: TNS:listener failed to start a dedicated server process

    I've accessed services via My Computer and can see that
    OracleOraHome81TNSListner has a status of 'Started' and is on Automatic....which is what it should be right?

    But OracleService[SID] does not have a status at all!! When I do start it up it takes a minute or so and then I receive a message from windows:

    Could not start the OracleServiceTESTDB service on Local Computer.
    Error 1053: The service did not respond to the start or control request in a timely fashion.

    The status for OracleServiceTESTDB then appears as Starting...

    When I attempt to logon on to a SQL Plus I then get the following message

    ERROR:
    ORA-01034: ORACLE not available

    Why is my database not starting up????

    Has anyone been successful in installing this version of ORACLE on XP home edition?

    I would appreciate any replies...

    Regards

    loopyfi

  2. #2
    Join Date
    Apr 2003
    Location
    Washington DC area
    Posts
    1,770

    Cool Re: New to Oracle :o(

    OK, it happend to the best of us. Look for the tnsnames.ora file and make sure the names match up with the sid you have. It's confusing but you get use to it. Also take a close loon at the tnsreadme file.

    Hope this helps.
    Big G

    Originally posted by loopyfi
    Hello

    I've just installed oracle 8i (Release 8.1.5.0.0) on XP home edition, I can't seem to log on to the database that I have set up. I get the following error:

    ERROR:
    ORA-12500: TNS:listener failed to start a dedicated server process

    I've accessed services via My Computer and can see that
    OracleOraHome81TNSListner has a status of 'Started' and is on Automatic....which is what it should be right?

    But OracleService[SID] does not have a status at all!! When I do start it up it takes a minute or so and then I receive a message from windows:

    Could not start the OracleServiceTESTDB service on Local Computer.
    Error 1053: The service did not respond to the start or control request in a timely fashion.

    The status for OracleServiceTESTDB then appears as Starting...

    When I attempt to logon on to a SQL Plus I then get the following message

    ERROR:
    ORA-01034: ORACLE not available

    Why is my database not starting up????

    Has anyone been successful in installing this version of ORACLE on XP home edition?

    I would appreciate any replies...

    Regards

    loopyfi

  3. #3
    Join Date
    Sep 2002
    Location
    Austria
    Posts
    37

    oradim

    instead of using the windows-services, you can always start the oracle-database (SID) manually on the (XP,win) command shell, like:

    C:\>oradim
    ORADIM: <command> [options]. Siehe Handbuch.
    Geben Sie einen der folgenden Befehle ein:
    Erstellen Sie eine Instanz durch Angabe der folgenden Parameter:
    -NEW -SID sid | -SRVC service [-INTPWD password] [-MAXUSERS number] [-STARTMODE a|m] [-PFILE file] [-TIMEOUT secs]
    Bearbeiten Sie eine Instanz durch Angabe der folgenden Parameter:
    -EDIT -SID sid [-NEWSID sid] [-INTPWD passwd] [-STARTMODE a|m] [-PFILE file] [-SHUTMODE a|i|n] [-SHUTTYPE srvc|inst]
    L÷schen Sie Instanzen durch Angabe von:
    -DELETE -SID sid | -SRVC Dienstname
    Fahren Sie Dienste und Instanz durch Angabe der folgenden Parameter hoch:
    -STARTUP -SID sid [-USRPWD password] [-STARTTYPE srvc|inst|srvc,inst] [-PFILE filename]
    Fahren Sie Dienste und Instanz durch Angabe der folgenden Parameter herunter:
    -SHUTDOWN -SID sid [-USRPWD password] [-SHUTTYPE srvc|inst|srvc,inst] [-SHUTMODE a | i | n]
    Fordern Sie einen Hilfetext durch Angabe der folgenden Parameter an: -? | -h | -help
    Sie haben eine ung³ltige Option f³r den Befehl -NEW angegeben

    your real command would then be like:

    C:\>oradim -startup -sid ORCL -usrpwd xxxxxx
    Last edited by pre4711; 08-23-03 at 04:15.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •