Results 1 to 3 of 3

Thread: Problem Jisql

  1. #1
    Join Date
    Mar 2003
    Posts
    4

    Unanswered: Problem Jisql

    Hello,

    I cannot launch Jisql in batch mode under Windows 2000 Pro.
    Here is my error message:
    java.lang.NullPointerException
    at com.sybase.jisql.HandleMessages.getLocalized(Handl eMessages.java:334)
    at com.sybase.jisql.HandleMessages.println(HandleMess ages.java:349)
    at com.sybase.jisql.HandleMessages.getBundle(Compiled Code)
    at com.sybase.jisql.HandleMessages.<init>(HandleMessa ges.java:276)
    at com.sybase.jisql.Jisql.main(Jisql.java:691)
    English

    I have checked http://my.sybase.com/detail?id=1010635 and it is ok (I've got the window titled SybSample so my environment variables seem to be ok).

    If I set the language of my Regional Settings into English, it is also ok. But I want to keep it in French.

    Does anyone any idea to solve this problem ?

    Thanks

  2. #2
    Join Date
    Oct 2003
    Location
    Roma,IT
    Posts
    1

    Smile Re: Problem Jisql

    Originally posted by vkim@slb.com
    Hello,

    I cannot launch Jisql in batch mode under Windows 2000 Pro.
    Here is my error message:
    java.lang.NullPointerException
    at com.sybase.jisql.HandleMessages.getLocalized(Handl eMessages.java:334)
    at com.sybase.jisql.HandleMessages.println(HandleMess ages.java:349)
    at com.sybase.jisql.HandleMessages.getBundle(Compiled Code)
    at com.sybase.jisql.HandleMessages.<init>(HandleMessa ges.java:276)
    at com.sybase.jisql.Jisql.main(Jisql.java:691)
    English

    I have checked http://my.sybase.com/detail?id=1010635 and it is ok (I've got the window titled SybSample so my environment variables seem to be ok).

    If I set the language of my Regional Settings into English, it is also ok. But I want to keep it in French.

    Does anyone any idea to solve this problem ?

    Thanks
    you can edit jisql.bat and modify the line:

    :runjisql
    %JAVAVM% "%VMCLASSPATH%" -Duser.language=EN -Duser.country=US com.sybase.jisql.Jisql %jisqlParams%
    goto end

    it set the locale to US only for this application

    good job!

  3. #3
    Join Date
    Mar 2003
    Posts
    4
    Hello,

    OK I've tried and it works !

    Thanks for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •