Results 1 to 2 of 2

Thread: ORA-00600 error

  1. #1
    Join Date
    Nov 2002

    Unanswered: ORA-00600 error

    i have a procedure that calculate the sum group by dates.

    the dates column datatype is timestamp, so i have to use
    to_char(dates, 'YYYYMMDD') to group by each day.

    right now it's taking about 3 mins to search thru 25xxxx records which I feel can use some improvement.

    i tried adding an bitmap index to it:
    create bitmap index CAL_DATETIME_IDX on lmsreport.current_auth_logs
    (to_char(datetime, 'YYYYMMDD'));

    but after doing that, whenever i run the procedure, i get a ora-00600 error. the procedure is fine if i remove the index

    can anyone help??



  2. #2
    Join Date
    Mar 2002
    Reading, UK
    ora-600 is an internal error i.e. an oracle bug so instead of using a bitmap index (is it really a low cardinality column?) try creating a normal index or look in metalink to see if there is a patch for your version of oracle (or you may need to upgrade to a new version of oracle).


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts