Results 1 to 1 of 1
  1. #1
    Join Date
    Apr 2002

    Question Unanswered: access97 nz function now broken

    any idea why the nz function does work in my vba code (form module)? i think the problem may be related to the jetcomp.exe i ran as the default destination db format is 4 and i may have used that by mistake. I've tried compacting again and creating a new db and importing the objects but still no luck - keep getting the infamous "undefined function nz() in expression" error at run-time. module compiles at design time but i get "Compile error - Method or data member not found" at run-time.

    the function appears in the object browser in the Access 8.0 Object Library but even explicitly referencing it (Application.NZ() doesn't work. ARGHH! i would think it's just not available in VBA but it was working fine yesterday.

    the references dialog shows the correct path for the 3 references (c:\program files\common files\microsoft shared\vba\vba332.dll - C\Program Files\Microsoft Office\Office\MSACC8.OLB - c:\program files\common files\microsoft shared\dao\dao350.dll). de-selecting/re-selecting it didn't help

    thx in advance for any suggestions

    Last edited by jmion; 08-29-03 at 10:50.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts